Inconsistent OIDC token issuer validation in Octopus Server
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Octopus Server from 2024.1.0 before 2026.1.11781, from 2026.2.0 before 2026.2.13438 and from 2026.3.0 before 2026.3.15816 validates OIDC token issuers inconsistently. This flaw (CWE-1289) lets a token from a suitably configured non-legitimate issuer pass as a token for a service account tied to a trusted issuer. An attacker with low privileges must target a service account with at least one OIDC identity configured and know or guess details of that identity.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
In affected versions of Octopus Server, OIDC token issuer validation was performed inconsistently. This could result in a token issued from a suitably configured non legitimate issuer being accepted as a token belonging to a service account from a legitimate trusted issuer. Exploitation requires a service account with at least one OIDC identity configured. An attacker would also need to know or guess some details of that identity in order to be in a position to attempt exploitation.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2024.1.0 to before 2026.1.11781; 2026.2.0 to before 2026.2.13438; 2026.3.0 to before 2026.3.15816 | 2026.1.11781, 2026.2.13438, 2026.3.15816 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2024.1.0 to before 2026.1.11781; 2026.2.0 to before 2026.2.13438; 2026.3.0 to before 2026.3.15816 Fixed in 2026.1.11781, 2026.2.13438, 2026.3.15816 Patch available CNA
Remediation
Octopus Server fixed versions are 2026.1.11781, 2026.2.13438 and 2026.3.15816.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2026.1.11781, 2026.2.13438, 2026.3.15816
Timeline
- 2026-10-27 Threatist record created from CVE-2026-116870
- 2026-10-27 Alias added: GHSA-j58f-w66m-94wj
- 2026-10-28 Priority changed: MEDIUM → LOW
- 2026-11-04 CISA SSVC decision points changed
References
More Octopus Deploy vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2021-11816 Deserialization of untrusted data in Octopus Deploy Halibut CVSS 3.1CRITICAL 9.8
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-116870 · CVE Program
- CVE-2026-116870 · NVD
- FIRST EPSS
- GHSA-j58f-w66m-94wj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences