Path traversal in Octopus Server lets uploaders run scripts outside directory
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Octopus Server versions from 2023.0.0 before 2026.1.674, from 2026.1 before 2026.1.674, from 2026.2 before 2026.2.973, and from 2026.3 before 2026.3.5839 are affected. A user with permission to upload a NuGet package can deploy a script step so that the script runs outside the parent directory, which is a path traversal flaw (CWE-22). An attacker needs high privileges and the impact is limited to low integrity and availability loss.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
Description from the CNA
In affected versions of Octopus Server, a user with permission to upload a malicious nuget package is able to deploy a script step so the script executes outside of the parent directory.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Octopus Deploy | Octopus Server | 2023.0.0 to before 2026.1.674; 2026.1 to before 2026.1.674; 2026.2 to before 2026.2.973; 2026.3 to before 2026.3.5839 | 2026.1.674, 2026.2.973, 2026.3.5839 | Patch available | CNA |
- Octopus Server VendorOctopus Deploy Affected 2023.0.0 to before 2026.1.674; 2026.1 to before 2026.1.674; 2026.2 to before 2026.2.973; 2026.3 to before 2026.3.5839 Fixed in 2026.1.674, 2026.2.973, 2026.3.5839 Patch available CNA
Remediation
Upgrade Octopus Server to 2026.1.674, 2026.2.973, or 2026.3.5839, or a later version of the same branch.
Written with Claude Haiku 5.5 from the sources below · 2026-11-04
- Fix · CNA Octopus Server (Octopus Deploy) Fixed in 2026.1.674, 2026.2.973, 2026.3.5839
Timeline
- 2026-10-27 Threatist record created from CVE-2026-12887
- 2026-10-27 Alias added: GHSA-7cvm-rc3q-qjrq
- 2026-11-04 Weakness changed · CISA ADP
- 2026-11-04 CISA SSVC decision points changed
References
More Octopus Deploy vulnerabilities
- TI-2018-13353 In Octopus Deploy 2018.8.0 through 2018.9.x before 2018.9.1, an authenticated user with… CVSS 3.0HIGH 8.8
- TI-2022-02375 Improper authentication in Octopus Server CVSS 3.1CRITICAL 9.8
- TI-2022-02579 Insufficient session expiration in Octopus Server CVSS 3.1CRITICAL 9.1
- TI-2021-11816 Deserialization of untrusted data in Octopus Deploy Halibut CVSS 3.1CRITICAL 9.8
- TI-2018-08066 In Octopus Deploy 2018.4.4 through 2018.5.1, Octopus variables that are sourced from the… CVSS 3.0CRITICAL 9.8
- TI-2022-02575 In affected versions of Octopus Deploy it is possible to bypass rate limiting on login using null bytes. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2026-12887 · CVE Program
- CVE-2026-12887 · NVD
- FIRST EPSS
- GHSA-7cvm-rc3q-qjrq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences