pgAdmin 4 libpq reuses the service account's Kerberos credentials
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-522.
Summary
pgAdmin 4 before 9.19 falls back to the Kerberos credentials of the operating-system account running pgAdmin when a connection should not use delegated credentials. libpq answers any server that requests GSSAPI authentication with that account's ticket, so in server mode any pgAdmin user can connect as the service account's Kerberos principal (CWE-522). Setting gssencmode=disable does not prevent this, and on Windows SSPI uses the service account's logon in the same way.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
Description from the CNA
When a pgAdmin 4 connection was not meant to use a Kerberos user's delegated credentials, pgAdmin removed KRB5CCNAME from its environment, so the Kerberos library fell back to the default credential cache, or a client keytab, of the operating-system account running pgAdmin. libpq then answered any server that asked for GSSAPI authentication with that account's ticket, whatever user name the pgAdmin user gave, so in server mode any user could connect as the service account's Kerberos principal; gssencmode=disable did not prevent it. On Windows, SSPI used the service account's logon in the same way. psql was also started with pgAdmin's environment, which could hold another user's credential cache while that user was connecting. The fix points KRB5CCNAME and KRB5_CLIENT_KTNAME at a file that cannot exist except while a Kerberos-authenticated user connects with Kerberos, and gives every other connection, psql and the utilities require_auth=!gss,!sspi and gssencmode=disable, checked on the final connection string. require_auth needs libpq 16 or later. This issue affects pgAdmin 4: before 9.19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | before 9.19 | 9.19 | Patch available | CNA |
- pgAdmin 4 Vendorpgadmin.org Affected before 9.19 Fixed in 9.19 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:*:*:* | before 9.19 | Vulnerable | pgadmin.org |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:*:*:* Versions before 9.19 Vulnerable ·pgadmin.org
Remediation
Upgrade pgAdmin 4 to 9.19, which points KRB5CCNAME and KRB5_CLIENT_KTNAME at a file that cannot exist except during Kerberos-authenticated connections and sets require_auth=!gss,!sspi and gssencmode=disable on all other connections. The require_auth setting needs libpq 16 or later.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
- Fix · CNA pgAdmin 4 (pgadmin.org) Fixed in 9.19
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
pgadmin.org pgAdmin 4 9.19
15 records Highest priority Priority MEDIUM 3 MEDIUM, 12 LOW
Other records, highest priority first
- TI-2026-83355 Command execution via backslash bypass in pgAdmin 4 query exportPriority MEDIUM 42
- TI-2026-83352 Failed login limit bypass in pgAdmin 4 allows unlimited password guessingPriority MEDIUM 42
- TI-2026-83353 pgAdmin 4 LDAP or Kerberos login opens another account by usernamePriority MEDIUM 41
Timeline
- 2026-10-30 Threatist record created from CVE-2026-116244
- 2026-10-30 Alias added: GHSA-5539-rjhp-jvgv
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-04 CVSS score added · NVD
- 2026-11-06 CISA SSVC decision points changed
References
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-116244 · CVE Program
- CVE-2026-116244 · NVD
- FIRST EPSS
- GHSA-5539-rjhp-jvgv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences