pgAdmin 4 libpq reuses the service account's credentials
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Attack requirements
- Present
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-522.
Summary
pgAdmin 4 before 9.19 leaves connection parameters unset when a server has no password file, client certificate or client key configured, or when the configured file cannot be found. libpq then falls back to the default credential files of the operating-system account running pgAdmin, an insecure default (CWE-1188) that exposes that account's saved passwords and client certificate. In server mode, any user can connect to a server with those credentials, and a copy of the public certificate is enough for libpq to pair it with the service account's private key.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
Description from the CNA
When a server in pgAdmin 4 had no password file, client certificate or client key configured, or the configured one could not be found, pgAdmin left the parameter out of the connection and libpq fell back to the defaults of the operating-system account running pgAdmin: ~/.pgpass, ~/.postgresql/postgresql.crt and postgresql.key, or PGPASSFILE, PGSSLCERT and PGSSLKEY. In server mode any user could therefore connect to a server with the service account's saved passwords or client certificate, and supplying only a copy of its public certificate was enough for libpq to pair it with the service account's private key. A pg_service.conf entry, or a maintenance database name read as a connection string by pg_dumpall, could bring the same files back for the utilities. The fix gives each of these parameters a value in server mode, the user's own file or otherwise a path that can never be opened, in the connection string, in the environment of the utilities and in the --dbname connection string that ranks above a service entry. Desktop mode is unchanged. This issue affects pgAdmin 4: before 9.19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | before 9.19 | 9.19 | Patch available | CNA |
- pgAdmin 4 Vendorpgadmin.org Affected before 9.19 Fixed in 9.19 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:*:*:* | before 9.19 | Vulnerable | pgadmin.org |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:*:*:* Versions before 9.19 Vulnerable ·pgadmin.org
Remediation
Upgrade pgAdmin 4 to version 9.19, the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-31
- Fix · CNA pgAdmin 4 (pgadmin.org) Fixed in 9.19
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
pgadmin.org pgAdmin 4 9.19
15 records Highest priority Priority MEDIUM 3 MEDIUM, 12 LOW
Other records, highest priority first
- TI-2026-83355 Command execution via backslash bypass in pgAdmin 4 query exportPriority MEDIUM 42
- TI-2026-83352 Failed login limit bypass in pgAdmin 4 allows unlimited password guessingPriority MEDIUM 42
- TI-2026-83353 pgAdmin 4 LDAP or Kerberos login opens another account by usernamePriority MEDIUM 41
Timeline
- 2026-10-30 Threatist record created from CVE-2026-116247
- 2026-10-30 Alias added: GHSA-47h8-x372-g8v3
- 2026-11-01 Priority changed: MEDIUM → LOW
- 2026-11-04 CVSS score added · NVD
- 2026-11-06 CISA SSVC decision points changed
References
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2026-116247 · CVE Program
- CVE-2026-116247 · NVD
- FIRST EPSS
- GHSA-47h8-x372-g8v3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences