PHP object injection in QA Assistants plugin leads to code execution
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
The QA Assistants plugin for WordPress is affected up to and including 5.3.0. Unsafe PHP deserialization of untrusted data (CWE-502) in the dlevent_ver parameter lets attackers inject a PHP object, and path traversal sequences in raw_name are not sanitized. An unauthenticated remote attacker can use a gadget in the bundled Guzzle dependency to write arbitrary files, which can lead to remote code execution.
Written with Claude Haiku 5.5 from the sources below · 2026-11-07
Description from the CNA
The QA Assistants – Driven by data plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 5.3.0 via the 'dlevent_ver' parameter. This is due to unrestricted PHP deserialization via wrap_unserialize_static() calling unserialize() without an allowed_classes restriction, combined with serialize_escape() failing to sanitize path traversal sequences in the raw_name parameter. This makes it possible for unauthenticated attackers to inject a PHP Object. The Guzzle FileCookieJar gadget present in the plugin's bundled Composer dependencies can be leveraged to perform an Arbitrary File Write, writing attacker-controlled content to an attacker-chosen filename, which can result in Remote Code Execution. Exploitation requires triggering the qahm_cron_data_manage scheduled event via wp-cron.php to invoke the deserialization sink against a planted queue file, but this endpoint requires no authentication and fires automatically on a two-minute schedule.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
The sources list no fixed version for the QA Assistants plugin.
Written with Claude Haiku 5.5 from the sources below · 2026-11-07
Timeline
- 2026-11-07 Threatist record created from CVE-2026-87112
- 2026-11-07 Alias added: GHSA-6gfw-3qvp-fj85
- 2026-11-08 Priority changed: MEDIUM → LOW
- 2026-11-08 CISA SSVC decision points changed
- 2026-11-08 Priority changed: LOW → MEDIUM
References
Other 9
- https://www.wordfence.com/threat-intel/vulnerabilities/id/76c5b5f1-a04b-4219-b8c0-ee53139fa787?source=cve
- https://plugins.trac.wordpress.org/browser/qa-heatmap-analytics/tags/5.2.0.1/class-qahm-base.php#L701
- https://plugins.trac.wordpress.org/browser/qa-heatmap-analytics/tags/5.2.0.1/class-qahm-admin-page-realtime.php#L183
- https://plugins.trac.wordpress.org/browser/qa-heatmap-analytics/tags/5.2.0.1/vendor/guzzlehttp/guzzle/src/Cookie/FileCookieJar.php#L38
- https://plugins.trac.wordpress.org/browser/qa-heatmap-analytics/tags/5.2.0.1/class-qahm-cron-proc.php#L698
- https://plugins.trac.wordpress.org/browser/qa-heatmap-analytics/tags/5.2.0.1/class-qahm-core-base.php#L780
- https://plugins.trac.wordpress.org/browser/qa-heatmap-analytics/tags/5.2.0.1/qahm-ajax.php#L319
- https://plugins.trac.wordpress.org/browser/qa-heatmap-analytics/tags/5.2.0.1/class-qahm-behavioral-data.php#L770
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3728466%40qa-heatmap-analytics&new=3728466%40qa-heatmap-analytics
More QuarkA vulnerabilities
- TI-2026-21938 WordPress QA Analytics plugin <= 5.2.0.0 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 10.0
- TI-2026-69998 Sensitive data exposure in QuarkA QA Analytics WordPress plugin CVSS 4.0MEDIUM 6.9
- TI-2026-80060 Stored cross-site scripting in QuarkA QA Analytics WordPress plugin CVSS 3.1HIGH 7.1
- TI-2024-07891 QA Analytics <= 4.1.1.1 - Missing Authorization to Unauthenticated Settings Update CVSS 3.1MEDIUM 5.3
Sources
- CVE-2026-87112 · CVE Program
- CVE-2026-87112 · NVD
- FIRST EPSS
- GHSA-6gfw-3qvp-fj85 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences