Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

17 records

Priority MEDIUM 55

The MapPress Maps for WordPress plugin before 2.93 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfi…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00326 Published 2025-05-15 Fixed in 2.93 CWE-79
Priority MEDIUM 55

The MapPress Maps for WordPress plugin before 2.94.10 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the u…

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00396 Published 2025-04-18 Fixed in 2.94.10 CWE-79
Priority HIGH 65

The MapPress Maps for WordPress plugin before 2.94.9 does not sanitise and escape some parameters when outputing them in the page, which could allow users with a role as low as contributor to perform Cross-Site Scripting…

CVSS 3.1MEDIUM 6.8 Network High privileges User interaction EPSS 0.00472 Published 2025-04-03 Fixed in 2.94.9 CWE-79
Priority LOW 28

The MapPress Maps for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Map block in all versions up to, and including, 2.94.1 due to insufficient input sanitization and output…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00279 Published 2024-11-06 No fix listed CWE-79
Priority MEDIUM 60

The MapPress Maps for WordPress plugin before 2.88.15 does not sanitize and escape the map title when outputting it back in the admin dashboard, allowing Contributors and above roles to perform Stored Cross-Site Scriptin…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00462 Published 2024-02-12 Fixed in 2.88.15 CWE-79
Priority MEDIUM 57

The MapPress Maps for WordPress plugin before 2.88.16 is affected by an IDOR as it does not ensure that posts to be retrieve via an AJAX action is a public map, allowing unauthenticated users to read arbitrary private an…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.00606 Published 2024-02-12 Fixed in 2.88.16 CWE-639
Priority LOW 29

The MapPress Maps for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the width and height parameters in all versions up to, and including, 2.88.16 due to insufficient input sanitization a…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00491 Published 2024-01-30 No fix listed CWE-79
Priority MEDIUM 62

The MapPress Maps for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the map title parameter in all versions up to and including 2.88.13 due to insufficient input sanitization and output…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00542 Published 2024-01-03 No fix listed CWE-79
Priority MEDIUM 50

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Chris Richardson MapPress Maps for WordPress mappress-google-maps-for-wordpress allows SQL Injection.This issue affect…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00734 Published 2023-11-03 No fix listed CWE-89
Priority LOW 29

The MapPress Maps for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'mappress' shortcode in versions up to, and including, 2.88.4 due to insufficient input sanitization and output escapi…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00551 Published 2023-09-12 No fix listed CWE-79
Priority LOW 35

The MapPress Maps for WordPress plugin before 2.73.13 allows a high privileged user to bypass the DISALLOW_FILE_EDIT and DISALLOW_FILE_MODS settings and upload arbitrary files to the site through the "ajax_save" function…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.01507 Published 2022-04-04 Fixed in 2.73.13 CWE-434
Priority LOW 31

The MapPress Maps for WordPress plugin before 2.73.4 does not sanitise and escape the mapid parameter before outputting it back in the "Bad mapid" error message, leading to a Reflected Cross-Site Scripting

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.02031 Published 2022-02-14 Fixed in 2.73.4 CWE-79
Priority MEDIUM 43

The mappress-google-maps-for-wordpress plugin before 2.54.6 for WordPress does not correctly implement capability checks for AJAX functions related to creation/retrieval/deletion of PHP template files, leading to Remote…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.02842 Published 2020-05-29 No fix listed CWE-434