Read the docs

Vulnerabilities

Filters

Reset all
Threatist priority
Signals
Fix status
Impact type
Attack vector
Requirements
Product

Products as named in CPE, with their records.

Published
Weakness (CWE)
1 selected

16 records

Priority HIGH 72

Versions of the package semver before 7.5.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the function new Range, when untrusted user data is provided as a range.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.02761 Published 2023-06-21 Partial fix · 7.5.2, 6.3.1 +1 CWE-1333
Priority MEDIUM 46

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.04004 Published 2022-06-13 Partial fix · 8.11.0 CWE-200
Priority LOW 36

`@npmcli/arborist`, the library that calculates dependency trees and manages the node_modules folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and the…

CVSS 3.1HIGH 8.2 Local No auth User interaction EPSS 0.00564 Published 2021-08-31 Fixed in 2.8.2 CWE-61
Priority LOW 36

`@npmcli/arborist`, the library that calculates dependency trees and manages the `node_modules` folder hierarchy for the npm command line interface, aims to guarantee that package dependency contracts will be met, and th…

CVSS 3.1HIGH 8.2 Local No auth User interaction EPSS 0.00588 Published 2021-08-31 Fixed in 2.8.2 CWE-61
TI-2021-15587 CVE-2021-37712 · GHSA-qq89-hq3f-393p

Path traversal in npm node-tar

Priority MEDIUM 41

The npm package "tar" (aka node-tar) before versions 4.4.18, 5.0.10, and 6.1.9 has an arbitrary file creation/overwrite and arbitrary code execution vulnerability.

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.01865 Published 2021-08-31 Partial fix · 4.4.18, 5.0.10 +1 CWE-22
TI-2021-15576 CVE-2021-37701 · GHSA-9r2w-394v-53qc

Path traversal in npm node-tar

Priority MEDIUM 43

The npm package "tar" (aka node-tar) before versions 4.4.16, 5.0.8, and 6.1.7 has an arbitrary file creation/overwrite and arbitrary code execution vulnerability.

CVSS 3.1HIGH 8.6 Local No auth User interaction EPSS 0.03286 Published 2021-08-31 Partial fix · 4.4.16, 5.0.8 +1 CWE-22
Priority LOW 30

The package hosted-git-info before 3.0.8 are vulnerable to Regular Expression Denial of Service (ReDoS) via regular expression shortcutMatch in the fromUrl function in index.js.

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.03612 Published 2021-03-23 Partial fix · 3.0.8, 2.8.9 CWE-1333
Priority LOW 21

Versions of the npm CLI prior to 6.14.6 are vulnerable to an information exposure vulnerability through log files.

CVSS 3.1MEDIUM 4.4 Local Low privileges User interaction EPSS 0.00404 Published 2020-07-07 Partial fix · 6.14.6 CWE-532
TI-2019-12557 CVE-2019-16777 · GHSA-4328-8hgf-7wjr

Arbitrary File Overwrite in npm CLI

Priority LOW 38

Versions of the npm CLI prior to 6.13.4 are vulnerable to an Arbitrary File Overwrite.

CVSS 3.1HIGH 7.7 Network Low privileges User interaction EPSS 0.02126 Published 2019-12-13 Partial fix · 6.13.4 CWE-22
Priority LOW 34

An issue was discovered in an npm 5.7.0 2018-02-21 pre-release (marked as "next: 5.7.0" and therefore automatically installed by an "npm upgrade -g npm" command, and also announced in the vendor's blog without mention of…

CVSS 3.0HIGH 7.8 Local Low privileges No interaction EPSS 0.0032 Published 2018-02-22 Fixed in 5.7.1 CWE-732
Priority MEDIUM 41

The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10 before 0.10.44, 0.12 before 0.12.13, 4 before 4.4.2, and 5 before 5.10.0, includes bearer tokens with arbitrary requests, which allows remote HTT…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.05456 Published 2016-07-02 Partial fix · 2.15.1, 3.8.3 CWE-200