Read the docs

NodeJS

Records296All Threatist records
Exploited (KEV)2In CISA KEV
CVSS critical26CVSS 9.0–10.0
CVSS high144CVSS 7.0–8.9

Exploited now

NodeJS records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

187 records in Node.js · all components

TI-2026-79288 CVE-2026-111497 · GHSA-9v8h-qqgm-4m35

Out-of-bounds write in Google Brotli decoder

Priority CRITICAL 99KEV

A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, dis…

CVSS 4.0CRITICAL 9.2 Network No auth No interaction EPSS 0.82641 Published 2026-10-22 Partial fix · 1.0.10, 1.1.1 +2 CWE-252
Priority HIGH 82

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.92488 Published 2022-11-01 Partial fix · 3.0.7, 300.0.11 CWE-120
TI-2022-03315 CVE-2022-3602 · GHSA-8rwr-x37p-mx23

X.509 Email Address 4-byte Buffer Overflow

Priority HIGH 82

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.9077 Published 2022-11-01 Fixed in 300.0.11 CWE-787
Priority HIGH 77

The BN_mod_sqrt() function, which computes a modular square root, contains a bug that can cause it to loop forever for non-prime moduli.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.73188 Published 2022-03-15 Partial fix · 300.0.5, 111.18.0 CWE-835
TI-2023-09717 CVE-2023-23919 · GHSA-mfq6-mjjx-mp7f

Cryptographic flaw in NodeJS Node

Priority HIGH 72

A cryptographic vulnerability exists in Node.js <19.2.0, <18.14.1, <16.19.1, <14.21.3 that in some cases did does not clear the OpenSSL error stack after operations that may set it.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.02209 Published 2023-02-23 Partial fix · 14.21.3, 16.19.1 +2 CWE-310
Priority HIGH 72

Node.js before 10.24.0, 12.21.0, 14.16.0, and 15.10.0 is vulnerable to a denial of service attack when too many connection attempts with an 'unknownProtocol' are established.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.77385 Published 2021-03-03 Partial fix · 10.24.0, 12.21.0 +2 CWE-400
TI-2021-06204 CVE-2021-23840 · GHSA-qgm6-9472-pwq7

Integer overflow in CipherUpdate

Priority HIGH 70

Calls to EVP_CipherUpdate, EVP_EncryptUpdate and EVP_DecryptUpdate may overflow the output length argument in some cases where the input length is close to the maximum permissable length for an integer on the platform.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.50732 Published 2021-02-16 Partial fix · 111.14.0 CWE-190
TI-2018-00680 CVE-2018-0732 · GHSA-497c-86pp-222m

Client DoS due to large DH parameter

Priority HIGH 69

During key agreement in a TLS handshake using a DH(E) based ciphersuite a malicious server can send a very large prime value to the client.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.4701 Published 2018-06-12 Partial fix CWE-320
Priority HIGH 69

The AES-NI implementation in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h does not consider memory allocation during a certain padding check, which allows remote attackers to obtain sensitive cleartext information via a…

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.89058 Published 2016-05-05 Partial fix CWE-200
TI-2021-05792 CVE-2021-22931 · GHSA-7r9p-c88x-w357

Improper input validation in NodeJS Node

Priority HIGH 68

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to Remote Code Execution, XSS, Application crashes due to missing input validation of host names returned by Domain Name Servers in Node.js dns library which can…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.21952 Published 2021-08-16 Partial fix · 12.22.5, 14.17.5 +1 CWE-170
TI-2021-05791 CVE-2021-22930 · GHSA-gqhp-5j32-xwmm

Use after free in NodeJS Node

Priority HIGH 68

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.36453 Published 2021-10-07 Partial fix · 12.22.4, 14.17.4 +1 CWE-416
Priority HIGH 68

An OpenSSL TLS server may crash if sent a maliciously crafted renegotiation ClientHello message from a client.

CVSS 3.1MEDIUM 5.9 Network No auth No interaction EPSS 0.63542 Published 2021-03-25 Fixed in 111.15.0 CWE-476
Load more
Open these records in search →