The WP VR WordPress plugin before 8.2.9 does not sanitise and escape some parameters before outputting them back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users s…
CVSS 3.1MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.00458·Published 2023-04-17·Fixed in 8.2.9
The WP VR WordPress plugin before 8.2.7 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor…
CVSS 3.1MEDIUM 5.4·Network·Low privileges·User interaction·EPSS 0.00649·Published 2023-02-06·Fixed in 8.2.7CWE-79
The WP VR WordPress plugin before 8.3.0 does not have authorisation and CSRF checks in various AJAX actions, one in particular could allow any authenticated users, such as subscriber to update arbitrary tours
CVSS 3.1MEDIUM 4.3·Network·Low privileges·No interaction·EPSS 0.00247·Published 2023-04-24·Fixed in 8.3.0CWE-352
The WP VR – 360 Panorama and Free Virtual Tour Builder For WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘hotspot-hover’ parameter in all versions up to, and including, 8.5.32 due to…
The WP VR WordPress plugin before 8.3.15 does not authorisation and CSRF in a function hooked to admin_init, allowing unauthenticated users to downgrade the plugin, thus leading to Reflected or Stored XSS, as previous ve…
CVSS 3.1MEDIUM 6.1·Network·No auth·User interaction·EPSS 0.00219·Published 2024-01-08·Fixed in 8.3.15CWE-352