Read the docs
TI-2005-03417 Aliases CVE-2005-3621GHSA-wj42-52pv-wfj2

CRLF injection vulnerability in phpMyAdmin before 2.6.4-pl4 allows remote attackers to…

Priority LOW 26Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.

Summary

CRLF injection vulnerability in phpMyAdmin before 2.6.4-pl4 allows remote attackers to conduct HTTP response splitting attacks via unspecified scripts.

Why it matters now

EPSS 0.0156 75th percentileScored 2026-11-07
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 2.6.4-pl4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpmyadmin/phpmyadmin (Packagist)before 2.6.4-pl42.6.4-pl4Patch availableGHSA-wj42-52pv-wfj2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected before 2.6.4-pl4 Fixed in 2.6.4-pl4 Patch available GHSA-wj42-52pv-wfj2

CPE configurations NVD · 13

CPEVersionsRoleVendor
cpe:2.3:a:phpmyadmin:phpmyadmin:2.2.0:*:*:*:*:*:*:*2.2.0VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.2.7_pl1:*:*:*:*:*:*:*2.2.7_pl1VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.2_pl1:*:*:*:*:*:*:*2.5.2_pl1VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.3:*:*:*:*:*:*:*2.5.3VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.4:*:*:*:*:*:*:*2.5.4VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.5_pl1:*:*:*:*:*:*:*2.5.5_pl1VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.6_rc2:*:*:*:*:*:*:*2.5.6_rc2VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.7_pl1:*:*:*:*:*:*:*2.5.7_pl1VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.0_pl3:*:*:*:*:*:*:*2.6.0_pl3VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.1_pl3:*:*:*:*:*:*:*2.6.1_pl3VulnerablephpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.2.7_pl1:*:*:*:*:*:*:* Versions 2.2.7_pl1 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.2_pl1:*:*:*:*:*:*:* Versions 2.5.2_pl1 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.3:*:*:*:*:*:*:* Versions 2.5.3 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.4:*:*:*:*:*:*:* Versions 2.5.4 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.5_pl1:*:*:*:*:*:*:* Versions 2.5.5_pl1 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.6_rc2:*:*:*:*:*:*:* Versions 2.5.6_rc2 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.5.7_pl1:*:*:*:*:*:*:* Versions 2.5.7_pl1 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.0_pl3:*:*:*:*:*:*:* Versions 2.6.0_pl3 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.1_pl3:*:*:*:*:*:*:* Versions 2.6.1_pl3 Vulnerable ·phpMyAdmin
Show 3 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.2_pl1:*:*:*:*:*:*:*2.6.2_pl1VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.3_pl1:*:*:*:*:*:*:*2.6.3_pl1VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.4_pl3:*:*:*:*:*:*:*2.6.4_pl3VulnerablephpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.2_pl1:*:*:*:*:*:*:* Versions 2.6.2_pl1 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.3_pl1:*:*:*:*:*:*:* Versions 2.6.3_pl1 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:2.6.4_pl3:*:*:*:*:*:*:* Versions 2.6.4_pl3 Vulnerable ·phpMyAdmin

Remediation

  • Fix · GHSA-wj42-52pv-wfj2 phpmyadmin/phpmyadmin (Packagist) Fixed in 2.6.4-pl4 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2005-3621
  2. 2026-10-03 Alias added: GHSA-wj42-52pv-wfj2

References

  • TI-2009-01092 Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-09056 An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can… CVSS 3.1HIGH 8.8
  • TI-2020-14341 SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in… CVSS 3.1CRITICAL 9.8
  • TI-2016-04978 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not… CVSS 3.0CRITICAL 9.8
  • TI-2020-16362 An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before… CVSS 3.1CRITICAL 9.8
  • TI-2012-04350 phpMyAdmin 3.5.2.2, as distributed by the cdnetworks-kr-1 mirror during an unspecified… CVSS 2.0HIGH 7.5
See all 276 →

Sources