Priority CRITICAL 100KEV
Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allows remote attackers to inject arbitrary PHP code into a configuration file via the save action.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.96565 · Published 2009-03-26 · No fix listed CWE-94
Priority HIGH 83
An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.9835 · Published 2018-06-21 · Fixed in 4.8.2 CWE-287
Priority HIGH 82
SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in phpMyAdmin 5.x before 5.2.0 via the tbl_storage_engine or tbl_collation parameters to tbl_create.php.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.0176 · Published 2023-01-26 · Fixed in 5.0.2 CWE-89
Priority HIGH 82
phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not properly choose delimiters to prevent use of the preg_replace e (aka eval) modifier, which might allow remote attackers to execute…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.8094 · Published 2016-07-03 · Fixed in 4.0.10.16, 4.4.15.7 +1 CWE-94
Priority HIGH 78
An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before 5.0.3.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.63702 · Published 2020-10-10 · Fixed in 4.9.6, 5.0.3 CWE-89
Priority HIGH 71
phpMyAdmin 3.5.2.2, as distributed by the cdnetworks-kr-1 mirror during an unspecified time frame in 2012, contains an externally introduced modification (Trojan Horse) in server_sync.php, which allows remote attackers t…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.74515 · Published 2012-09-25 · No fix listed CWE-94
Priority MEDIUM 61
phpMyAdmin through 5.2.3 contains a server-side request forgery vulnerability that allows unauthenticated attackers to trigger outbound connections via setup/validate.php, which lacks the setup-disabled guard.
CVSS 4.0MEDIUM 6.3· Network · No auth · No interaction · EPSS 0.0034 · Published 2026-10-30 · No fix listed CWE-918
Priority MEDIUM 61
In phpMyAdmin 4 before 4.9.4 and 5 before 5.0.1, SQL injection exists in the user accounts page.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.28046 · Published 2020-01-09 · Fixed in 4.9.4, 5.0.1 CWE-89
Priority MEDIUM 56
phpMyAdmin 2.6.0-pl2, and other versions before 2.6.1, with external transformations enabled, allows remote attackers to execute arbitrary commands via shell metacharacters.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.11592 · Published 2004-12-15 · No fix listed
Priority MEDIUM 53
The Portable phpMyAdmin plugin before 1.3.1 for WordPress allows remote attackers to bypass authentication and obtain phpMyAdmin console access via a direct request to wp-content/plugins/portable-phpmyadmin/wp-pma-mod.
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.23745 · Published 2012-12-20 · No fix listed CWE-264
Priority MEDIUM 50
phpMyAdmin 3.5.x before 3.5.8 and 4.x before 4.0.0-rc3 allows remote authenticated users to execute arbitrary code via a /e\x00 sequence, which is not properly handled before making a preg_replace function call within th…
CVSS 2.0MEDIUM 6.0· Network · Low privileges · Interaction — · EPSS 0.28851 · Published 2013-04-26 · No fix listed
Priority MEDIUM 50
libraries/database_interface.lib.php in phpMyAdmin before 2.11.9.1 allows remote authenticated users to execute arbitrary code via a request to server_databases.php with a sort_by parameter containing PHP sequences, whic…
CVSS 2.0HIGH 8.5· Network · Low privileges · Interaction — · EPSS 0.11175 · Published 2008-09-17 · No fix listed CWE-20
Priority MEDIUM 49
phpMyAdmin versions 4.7.x (prior to 4.7.6.1/4.7.7) are vulnerable to a CSRF weakness.
CVSS 3.0HIGH 8.8· Network · No auth · User interaction · EPSS 0.08464 · Published 2018-01-03 · Fixed in 4.7.7 CWE-352
Priority MEDIUM 48
An issue was discovered in phpMyAdmin before 4.9.0.
CVSS 3.0MEDIUM 6.5· Network · No auth · User interaction · EPSS 0.2022 · Published 2019-06-05 · Fixed in 4.9.0 CWE-352
Priority MEDIUM 48
An issue was discovered in phpMyAdmin before 4.9.0.1.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03549 · Published 2019-06-05 · Fixed in 4.9.0.1 CWE-89
Priority MEDIUM 48
An issue was discovered in phpMyAdmin before 4.8.5.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03576 · Published 2019-01-26 · Fixed in 4.8.5 CWE-89
Priority MEDIUM 48
An issue was discovered in phpMyAdmin involving the $cfg['ArbitraryServerRegexp'] configuration directive.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03202 · Published 2016-12-11 · Fixed in 4.6.4, 4.4.15.8 +1 CWE-254
Priority MEDIUM 48
An issue was discovered in phpMyAdmin.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.03189 · Published 2016-12-11 · No fix listed CWE-502
Priority MEDIUM 48
The configuration setup script (aka scripts/setup.php) in phpMyAdmin 2.11.x before 2.11.10.1 does not properly restrict key names in its output file, which allows remote attackers to execute arbitrary PHP code via a craf…
CVSS 2.0HIGH 7.5· Network · No auth · Interaction — · EPSS 0.14831 · Published 2010-08-24 · No fix listed CWE-264
Priority MEDIUM 48
libraries/File.class.php in phpMyAdmin 2.11.x before 2.11.10 uses predictable filenames for temporary files, which has unknown impact and attack vectors.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.02739 · Published 2010-01-19 · Fixed in 2.11.10 CWE-310
Priority MEDIUM 48
libraries/File.class.php in phpMyAdmin 2.11.x before 2.11.10 creates a temporary directory with 0777 permissions, which has unknown impact and attack vectors.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.02714 · Published 2010-01-19 · No fix listed CWE-264
Priority MEDIUM 47
An issue was discovered in libraries/common.inc.php in phpMyAdmin 4.0 before 4.0.10.20, 4.4.x, 4.6.x, and 4.7.0 prereleases.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02818 · Published 2018-05-01 · Fixed in 4.0.10.20, 4.7.0 CWE-269
Priority MEDIUM 47
An issue was discovered in phpMyAdmin.
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02672 · Published 2016-12-11 · No fix listed CWE-264
Priority MEDIUM 47
SQL injection vulnerability in libraries/central_columns.lib.php in phpMyAdmin 4.4.x before 4.4.15.7 and 4.6.x before 4.6.3 allows remote attackers to execute arbitrary SQL commands via a crafted database name that is mi…
CVSS 3.0CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02323 · Published 2016-07-03 · No fix listed CWE-89
Priority MEDIUM 47
Multiple unspecified vulnerabilities in phpMyAdmin before 2.9.2-rc1 have unknown impact and attack vectors.
CVSS 2.0HIGH 10.0· Network · No auth · Interaction — · EPSS 0.0188 · Published 2007-01-11 · No fix listed
Load more