Read the docs
TI-2012-04542 Aliases CVE-2012-5368GHSA-xpxp-v33m-5jp9

phpMyAdmin 3.5.x before 3.5.3 uses JavaScript code that is obtained through an HTTP…

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Medium
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

phpMyAdmin 3.5.x before 3.5.3 uses JavaScript code that is obtained through an HTTP session to phpmyadmin.net without SSL, which allows man-in-the-middle attackers to conduct cross-site scripting (XSS) attacks by modifying this code.

Why it matters now

EPSS 0.0135 71st percentileScored 2026-11-07
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 3.5.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—phpmyadmin/phpmyadmin (Packagist)3.5 to before 3.5.33.5.3Patch availableGHSA-xpxp-v33m-5jp9
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 3.5 to before 3.5.3 Fixed in 3.5.3 Patch available GHSA-xpxp-v33m-5jp9

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.0.0:*:*:*:*:*:*:*3.5.0.0VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.1.0:*:*:*:*:*:*:*3.5.1.0VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.2.0:*:*:*:*:*:*:*3.5.2.0VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.2.1:*:*:*:*:*:*:*3.5.2.1VulnerablephpMyAdmin
cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.2.2:*:*:*:*:*:*:*3.5.2.2VulnerablephpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.0.0:*:*:*:*:*:*:* Versions 3.5.0.0 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.1.0:*:*:*:*:*:*:* Versions 3.5.1.0 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.2.0:*:*:*:*:*:*:* Versions 3.5.2.0 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.2.1:*:*:*:*:*:*:* Versions 3.5.2.1 Vulnerable ·phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:3.5.2.2:*:*:*:*:*:*:* Versions 3.5.2.2 Vulnerable ·phpMyAdmin

Remediation

  • Fix · GHSA-xpxp-v33m-5jp9 phpmyadmin/phpmyadmin (Packagist) Fixed in 3.5.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2012-5368
  2. 2026-10-03 Alias added: GHSA-xpxp-v33m-5jp9

References

  • TI-2009-01092 Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-09056 An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can… CVSS 3.1HIGH 8.8
  • TI-2020-14341 SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in… CVSS 3.1CRITICAL 9.8
  • TI-2016-04978 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not… CVSS 3.0CRITICAL 9.8
  • TI-2020-16362 An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before… CVSS 3.1CRITICAL 9.8
  • TI-2012-04350 phpMyAdmin 3.5.2.2, as distributed by the cdnetworks-kr-1 mirror during an unspecified… CVSS 2.0HIGH 7.5
See all 276 →

Sources