Read the docs
TI-2013-01996 Aliases CVE-2013-2233GHSA-9x6q-5423-w5v9

Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle…

Priority LOW 36CWE-320Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
—
Confidentiality · integrity · availability
High · High · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

Ansible before 1.2.1 makes it easier for remote attackers to conduct man-in-the-middle attacks by leveraging failure to cache SSH host keys.

Why it matters now

EPSS 0.01896 79th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.2.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—ansible (PyPI)before 1.2.11.2.1Patch availableGHSA-9x6q-5423-w5v9
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected before 1.2.1 Fixed in 1.2.1 Patch available GHSA-9x6q-5423-w5v9

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*before 1.2.1VulnerableRed Hat
  • cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions before 1.2.1 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-9x6q-5423-w5v9 ansible (PyPI) Fixed in 1.2.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2013-2233
  2. 2026-10-03 Alias added: GHSA-9x6q-5423-w5v9

References

  • TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
  • TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
  • TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
  • TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
See all 44 →

Sources