The safe_eval function in Ansible before 1.5.4 does not properly restrict the code…
Priority MEDIUM 49CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The safe_eval function in Ansible before 1.5.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.
Why it matters now
EPSS 0.04513 91st percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.5.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ansible (PyPI) | before 1.5.4 | 1.5.4 | Patch available | GHSA-qg47-5px9-32g7 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 1.5.4 Fixed in 1.5.4 Patch available GHSA-qg47-5px9-32g7
Remediation
- Fix · GHSA-qg47-5px9-32g7 ansible (PyPI) Fixed in 1.5.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Critical. Red Hat's page for this CVE →
Not affected: 8 products
- CloudForms Management Engine 5
- Red Hat Ansible Engine 2
- Red Hat Ansible Tower 3
- Red Hat Ceph Storage 2
- Red Hat Ceph Storage 3
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat OpenStack Platform 13 (Queens)
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2014-4657
- 2026-10-03 Alias added: GHSA-qg47-5px9-32g7
References
Other 5
- https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
- https://github.com/ansible/ansible/commit/998793fd0ab55705d57527a38cee5e83f535974c
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-199.yaml
- https://web.archive.org/web/20210120133852/https://www.securityfocus.com/bid/68232
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
- TI-2016-07090 Command injection in Red Hat Ansible CVSS 3.0CRITICAL 9.1
Sources
- CVE-2014-4657 · CVE Program
- CVE-2014-4657 · NVD
- FIRST EPSS
- GHSA-qg47-5px9-32g7 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-4657 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences