Read the docs

Red Hat

Records7414All Threatist records
Exploited (KEV)98In CISA KEV
CVSS critical793CVSS 9.0–10.0
CVSS high2681CVSS 7.0–8.9

Exploited now

Red Hat records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

45 records in Ansible · all components

TI-2016-07808 CVE-2016-9587 · GHSA-m956-frf4-m2wr

Improper input validation in Ansible

Priority MEDIUM 52

Ansible before versions 2.1.4, 2.2.1 is vulnerable to an improper input validation in Ansible's handling of data sent from client systems.

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.17006 Published 2018-04-24 Partial fix · 2.1.4.0, 2.2.1.0 CWE-20
TI-2014-03853 CVE-2014-4678 · GHSA-66c7-5pwv-mm3j

Injection in Ansible

Priority MEDIUM 50

The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.05341 Published 2020-02-20 Fixed in 1.6.4 CWE-74
Priority MEDIUM 48

A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0353 Published 2017-11-21 Partial fix · 2.4.1.0, 2.3.3.0 CWE-532
Priority MEDIUM 48

Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote attackers to execute arbitrary code by leveraging access to an Ansible managed host and providing a crafted fact, as demonstrated by a fact…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03521 Published 2020-02-18 Fixed in 1.6.7 CWE-74
Priority MEDIUM 48

Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings, and does not prevent remote data with "{{" substrings, which allows remote attackers to execute arbitrary code via (1) crafted looku…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.03521 Published 2020-02-18 Fixed in 1.6.7 CWE-74
TI-2016-07090 CVE-2016-8628 · GHSA-jg4f-jqm5-4mgq

Command injection in Red Hat Ansible

Priority MEDIUM 45

Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller.

CVSS 3.0CRITICAL 9.1 Network High privileges No interaction EPSS 0.03211 Published 2018-07-31 Partial fix · 2.2.0.0 CWE-77
Priority MEDIUM 40

Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems.

CVSS 3.0HIGH 8.0 Network Low privileges User interaction EPSS 0.03005 Published 2018-06-22 Fixed in 2.2.3.0 CWE-20
TI-2023-05302 CVE-2023-5764 · GHSA-7j69-qfc3-2fq9

Ansible: template injection

Priority LOW 37

A template injection flaw was found in Ansible where a user's controller internal templating operations may remove the unsafe designation from template data.

CVSS 3.1HIGH 7.8 Local Low privileges No interaction EPSS 0.00574 Published 2023-12-12 Partial fix · 1:2.15.8-1.el8ap, 1:2.15.8-1.el9ap +3 CWE-1336
TI-2020-08587 CVE-2020-10684 · GHSA-p62g-jhg6-v3rq

Race condition in Red Hat Ansible

Priority LOW 34

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled,…

CVSS 3.1HIGH 7.9 Local Low privileges User interaction EPSS 0.00331 Published 2020-03-24 Partial fix · 2.7.17, 2.8.11 +1 CWE-362
Priority LOW 34

The create_script function in the lxc_container module in Ansible before 1.9.6-1 and 2.x before 2.0.2.0 allows local users to write to arbitrary files or gain privileges via a symlink attack on (1) /opt/.lxc-attach-scrip…

CVSS 3.0HIGH 7.8 Local Low privileges No interaction EPSS 0.00468 Published 2016-06-03 Fixed in 2.0.2.0, 1.9.6.1 CWE-59
Priority LOW 33

Ansible, versions 2.9.x before 2.9.1, 2.8.x before 2.8.7 and Ansible versions 2.7.x before 2.7.15, is not respecting the flag no_log set it to True when Sumologic and Splunk callback plugins are used send tasks results e…

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01857 Published 2020-01-02 Partial fix · 2.7.15, 2.8.7 +1 CWE-117
TI-2019-07537 CVE-2019-10217 · GHSA-p75j-wc34-527c

Information disclosure in Red Hat Ansible

Priority LOW 33

A flaw was found in ansible 2.8.0 before 2.8.4.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01853 Published 2019-11-25 Fixed in 2.8.4 CWE-200
TI-2019-11107 CVE-2019-14904 · GHSA-gwr8-5j83-483c

Improper input validation in Ansible

Priority LOW 32

A flaw was found in the solaris_zone module from the Ansible Community modules.

CVSS 3.1HIGH 7.3 Local High privileges No interaction EPSS 0.00418 Published 2020-08-25 Partial fix · 2.7.16, 2.8.8 +1 CWE-20
Priority LOW 32

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.01503 Published 2019-11-22 Partial fix · 2.8.4, 2.7.13 +1 CWE-522
TI-2018-12086 CVE-2018-16876 · GHSA-j569-fghw-f9rx

Information disclosure in Red Hat ansible

Priority LOW 29

ansible before versions 2.5.14, 2.6.11, 2.7.5 is vulnerable to a information disclosure flaw in vvv+ mode with no_log on that can lead to leakage of sensible data.

CVSS 3.1MEDIUM 5.3 Network Low privileges No interaction EPSS 0.02462 Published 2019-01-03 Partial fix · 2.5.14, 2.6.11 +1 CWE-200
TI-2019-07477 CVE-2019-10156 · GHSA-grgm-pph5-j5h7

Information disclosure in Red Hat ansible

Priority LOW 28

A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution.

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.01759 Published 2019-07-30 Partial fix · 2.6.18, 2.7.12 +1 CWE-200
Load more
Open these records in search →