lib/ansible/playbook/__init__.py in Ansible 1.2.x before 1.2.3, when playbook does not…
Priority LOW 16CWE-264Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
lib/ansible/playbook/__init__.py in Ansible 1.2.x before 1.2.3, when playbook does not run due to an error, allows local users to overwrite arbitrary files via a symlink attack on a retry file with a predictable name in /var/tmp/ansible/.
Why it matters now
EPSS 0.00329 26th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.2.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ansible (PyPI) | 1.2 to before 1.2.3 | 1.2.3 | Patch available | GHSA-pcqv-c46v-2p4v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected 1.2 to before 1.2.3 Fixed in 1.2.3 Patch available GHSA-pcqv-c46v-2p4v
Remediation
- Fix · GHSA-pcqv-c46v-2p4v ansible (PyPI) Fixed in 1.2.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-4260
- 2026-10-03 Alias added: GHSA-pcqv-c46v-2p4v
References
Other 5
- https://groups.google.com/forum/#%21topic/ansible-project/UVDYW0HGcNg
- https://github.com/ansible/ansible/commit/d5948d59fc863fcec6efa62fa2791928ffc5a6d1
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2013-2.yaml
- https://groups.google.com/forum/#!topic/ansible-project/UVDYW0HGcNg
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2013-4260 · CVE Program
- CVE-2013-4260 · NVD
- FIRST EPSS
- GHSA-pcqv-c46v-2p4v · GitHub Advisory Database · CC BY 4.0
- CVE-2013-4260 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences