Ansible prior to 1.5.4 mishandles the evaluation of some strings.
Priority LOW 35CWE-670Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Ansible prior to 1.5.4 mishandles the evaluation of some strings.
Why it matters now
EPSS 0.01213 68th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.5.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ansible (PyPI) | before 1.5.4 | 1.5.4 | Patch available | GHSA-49m5-2838-q2rv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 1.5.4 Fixed in 1.5.4 Patch available GHSA-49m5-2838-q2rv
Remediation
- Fix · GHSA-49m5-2838-q2rv ansible (PyPI) Fixed in 1.5.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-2686
- 2026-10-03 Alias added: GHSA-49m5-2838-q2rv
References
Other 5
- https://groups.google.com/forum/#%21searchin/ansible-project/1.5.4/ansible-project/MUQxiKwSQDc/id6aVaawVboJ
- https://github.com/ansible/ansible/commit/998793fd0ab55705d57527a38cee5e83f535974c
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-198.yaml
- https://groups.google.com/forum/#!searchin/ansible-project/1.5.4/ansible-project/MUQxiKwSQDc/id6aVaawVboJ
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2014-2686 · CVE Program
- CVE-2014-2686 · NVD
- FIRST EPSS
- GHSA-49m5-2838-q2rv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences