Read the docs
TI-2014-02825 Aliases CVE-2014-3498GHSA-4cvm-5776-jx9f

The user module in ansible before 1.6.6 allows remote authenticated users to execute arbitrary commands.

Priority MEDIUM 43CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

The user module in ansible before 1.6.6 allows remote authenticated users to execute arbitrary commands.

Why it matters now

EPSS 0.02592 85th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.6.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—ansible (PyPI)before 1.6.61.6.6Patch availableGHSA-4cvm-5776-jx9f
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected before 1.6.6 Fixed in 1.6.6 Patch available GHSA-4cvm-5776-jx9f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*up to 1.6.5VulnerableRed Hat
  • cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions up to 1.6.5 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-4cvm-5776-jx9f ansible (PyPI) Fixed in 1.6.6 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat OpenShift Enterprise 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-3498
  2. 2026-10-03 Alias added: GHSA-4cvm-5776-jx9f

References

  • TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
  • TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
  • TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
  • TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
See all 44 →

Sources