Command injection in Red Hat Ansible
Priority MEDIUM 45CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-77.
Summary
Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.
Why it matters now
EPSS 0.03211 88th percentileScored 2026-11-07
Fix Partial ansible (PyPI): 2.2.0.0Red Hat: 1 advisoryRed Hat: 2 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Ansible | 2.2.0 | — | No fix listed | CNA |
| — | ansible (PyPI) | before 2.2.0.0 | 2.2.0.0 | Patch available | GHSA-jg4f-jqm5-4mgq |
- Ansible VendorRed Hat Affected 2.2.0 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 2.2.0.0 Fixed in 2.2.0.0 Patch available GHSA-jg4f-jqm5-4mgq
Remediation
- Fix · GHSA-jg4f-jqm5-4mgq ansible (PyPI) Fixed in 2.2.0.0 Advisory →
Red Hat 1 advisory
- RHSA-2016:2778 Released 2016-11-15 · Red Hat rating Moderateatomic-openshift-utils security and bug fix update
- Red Hat OpenShift Container Platform 3.2 ansible-2.2.0.0-1.el7, atomic-openshift-utils-3.2.42-1.git.0.6b09be9.el7, openshift-ansible-3.2.42-1.git.0.6b09be9.el7 +5
- Red Hat OpenShift Container Platform 3.3 ansible-2.2.0.0-1.el7, atomic-openshift-utils-3.3.50-1.git.0.5bdbeaa.el7, openshift-ansible-3.3.50-1.git.0.5bdbeaa.el7 +6
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Quickstart Cloud Installer 1 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 3.2 | Fixed | RHSA-2016:2778 |
| Red Hat OpenShift Container Platform 3.3 | Fixed | RHSA-2016:2778 |
Not affected: 3 products
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat Storage 3
- Red Hat Storage Console 2
Timeline
- 2026-10-02 Threatist record created from CVE-2016-8628
- 2026-10-03 Alias added: GHSA-jg4f-jqm5-4mgq
References
Advisory 4
Other 5
- https://github.com/ansible/ansible/issues/41903
- https://github.com/ansible/ansible/commit/35938b907dfcd1106ca40b794f0db446bdb8cf09
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2018-38.yaml
- https://web.archive.org/web/20200227214455/http://www.securityfocus.com/bid/94109
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-8628 · CVE Program
- CVE-2016-8628 · NVD
- FIRST EPSS
- GHSA-jg4f-jqm5-4mgq · GitHub Advisory Database · CC BY 4.0
- CVE-2016-8628 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences