The vault subsystem in Ansible before 1.5.5 does not set the umask before creation or…
Priority LOW 25CWE-200Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The vault subsystem in Ansible before 1.5.5 does not set the umask before creation or modification of a vault file, which allows local users to obtain sensitive key information by reading a file.
Why it matters now
EPSS 0.00415 36th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.5.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ansible (PyPI) | before 1.5.5 | 1.5.5 | Patch available | GHSA-5g4v-2pc6-4hh4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 1.5.5 Fixed in 1.5.5 Patch available GHSA-5g4v-2pc6-4hh4
Remediation
- Fix · GHSA-5g4v-2pc6-4hh4 ansible (PyPI) Fixed in 1.5.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 8 products
- CloudForms Management Engine 5
- Red Hat Ansible Engine 2
- Red Hat Ansible Tower 3
- Red Hat Ceph Storage 2
- Red Hat Ceph Storage 3
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat OpenStack Platform 13 (Queens)
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2014-4658
- 2026-10-03 Alias added: GHSA-5g4v-2pc6-4hh4
References
Other 5
- https://github.com/ansible/ansible/blob/release1.5.5/CHANGELOG.md
- https://github.com/ansible/ansible/commit/a0e027fe362fbc209dbeff2f72d6e95f39885c69
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2020-200.yaml
- https://web.archive.org/web/20210120133853/https://www.securityfocus.com/bid/68233
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2014-4658 · CVE Program
- CVE-2014-4658 · NVD
- FIRST EPSS
- GHSA-5g4v-2pc6-4hh4 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-4658 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences