Read the docs
TI-2014-03841 Aliases CVE-2014-4659GHSA-6667-f46p-pg88

Ansible before 1.5.5 sets 0644 permissions for sources.list, which might allow local…

Priority LOW 25CWE-522Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-522.

Summary

Ansible before 1.5.5 sets 0644 permissions for sources.list, which might allow local users to obtain sensitive credential information in opportunistic circumstances by reading a file that uses the "deb http://user:pass@server:port/" format.

Why it matters now

EPSS 0.00362 30th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.5.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—ansible (PyPI)before 1.5.51.5.5Patch availableGHSA-6667-f46p-pg88
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • ansible (PyPI) Vendor— Affected before 1.5.5 Fixed in 1.5.5 Patch available GHSA-6667-f46p-pg88

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:*before 1.5.5VulnerableRed Hat
  • cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions before 1.5.5 Vulnerable ·Red Hat

Remediation

  • Fix · GHSA-6667-f46p-pg88 ansible (PyPI) Fixed in 1.5.5 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 8 products
  • CloudForms Management Engine 5
  • Red Hat Ansible Engine 2
  • Red Hat Ansible Tower 3
  • Red Hat Ceph Storage 2
  • Red Hat Ceph Storage 3
  • Red Hat OpenStack Platform 10 (Newton)
  • Red Hat OpenStack Platform 13 (Queens)
  • Red Hat Storage 3

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-4659
  2. 2026-10-03 Alias added: GHSA-6667-f46p-pg88

References

  • TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
  • TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
  • TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
  • TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
  • TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
See all 44 →

Sources