Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote…
Priority LOW 31CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote attackers to hijack the authentication of unspecified victims for requests that read a user OAuth authorization code via unknown vectors.
Why it matters now
EPSS 0.00654 51st percentileScored 2026-11-07
Fix Fixed doorkeeper (RubyGems): 1.4.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | doorkeeper (RubyGems) | before 1.4.1 | 1.4.1 | Patch available | GHSA-685w-vc84-wxcx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- doorkeeper (RubyGems) Vendor— Affected before 1.4.1 Fixed in 1.4.1 Patch available GHSA-685w-vc84-wxcx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:* | up to 1.4.0 | Vulnerable | Doorkeeper Project |
- cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:* Versions up to 1.4.0 Vulnerable ·Doorkeeper Project
Remediation
- Fix · GHSA-685w-vc84-wxcx doorkeeper (RubyGems) Fixed in 1.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-8144
- 2026-10-03 Alias added: GHSA-685w-vc84-wxcx
- 2026-10-14 EPSS moved to the 50th–90th percentile
References
More Doorkeeper Project Doorkeeper vulnerabilities
- TI-2023-17082 Doorkeeper Improper Authentication vulnerability CVSS 3.1MEDIUM 6.5
- TI-2016-05635 The Doorkeeper gem before 4.2.0 for Ruby might allow remote attackers to conduct replay… CVSS 3.0CRITICAL 9.1
- TI-2020-08208 Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that… CVSS 3.1HIGH 7.5
- TI-2018-15860 Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in… CVSS 3.0HIGH 7.5
- TI-2018-15743 Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS)… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2014-8144 · CVE Program
- CVE-2014-8144 · NVD
- FIRST EPSS
- GHSA-685w-vc84-wxcx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences