Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that allows an attacker to retrieve the client secret only intended for the OAuth application owner. After authorizing the application and allowing access, the attacker simply needs to request the list of their authorized applications in a JSON format (usually GET /oauth/authorized_applications.json). An application is vulnerable if the authorized applications controller is enabled.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | doorkeeper (RubyGems) | 5.0.0 to before 5.0.3 | 5.0.3 | Patch available | GHSA-j7vx-8mqj-cqp9 |
| — | doorkeeper (RubyGems) | 5.1.0 to before 5.1.1 | 5.1.1 | Patch available | GHSA-j7vx-8mqj-cqp9 |
| — | doorkeeper (RubyGems) | 5.2.0 to before 5.2.5 | 5.2.5 | Patch available | GHSA-j7vx-8mqj-cqp9 |
| — | doorkeeper (RubyGems) | 5.3.0 to before 5.3.2 | 5.3.2 | Patch available | GHSA-j7vx-8mqj-cqp9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- doorkeeper (RubyGems) Vendor— Affected 5.0.0 to before 5.0.3 Fixed in 5.0.3 Patch available GHSA-j7vx-8mqj-cqp9
- doorkeeper (RubyGems) Vendor— Affected 5.1.0 to before 5.1.1 Fixed in 5.1.1 Patch available GHSA-j7vx-8mqj-cqp9
- doorkeeper (RubyGems) Vendor— Affected 5.2.0 to before 5.2.5 Fixed in 5.2.5 Patch available GHSA-j7vx-8mqj-cqp9
- doorkeeper (RubyGems) Vendor— Affected 5.3.0 to before 5.3.2 Fixed in 5.3.2 Patch available GHSA-j7vx-8mqj-cqp9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:* | 5.0.0 to before 5.0.3; 5.1.0 to before 5.1.1; 5.2.0 to before 5.2.5; 5.3.0 to before 5.3.2 | Vulnerable | Doorkeeper Project |
- cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:* Versions 5.0.0 to before 5.0.3; 5.1.0 to before 5.1.1; 5.2.0 to before 5.2.5; 5.3.0 to before 5.3.2 Vulnerable ·Doorkeeper Project
Remediation
- Fix · GHSA-j7vx-8mqj-cqp9 doorkeeper (RubyGems) Fixed in 5.0.3 Advisory →
- Fix · GHSA-j7vx-8mqj-cqp9 doorkeeper (RubyGems) Fixed in 5.1.1 Advisory →
- Fix · GHSA-j7vx-8mqj-cqp9 doorkeeper (RubyGems) Fixed in 5.2.5 Advisory →
- Fix · GHSA-j7vx-8mqj-cqp9 doorkeeper (RubyGems) Fixed in 5.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2020-10187
- 2026-10-03 Alias added: GHSA-j7vx-8mqj-cqp9
References
Patch 3
Advisory 2
More Doorkeeper Project Doorkeeper vulnerabilities
- TI-2023-17082 Doorkeeper Improper Authentication vulnerability CVSS 3.1MEDIUM 6.5
- TI-2016-05635 The Doorkeeper gem before 4.2.0 for Ruby might allow remote attackers to conduct replay… CVSS 3.0CRITICAL 9.1
- TI-2018-15860 Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in… CVSS 3.0HIGH 7.5
- TI-2014-06759 Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote… CVSS 2.0MEDIUM 6.8
- TI-2018-15743 Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS)… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2020-10187 · CVE Program
- CVE-2020-10187 · NVD
- FIRST EPSS
- GHSA-j7vx-8mqj-cqp9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences