Read the docs

Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS)…

Priority LOW 30CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.

Why it matters now

EPSS 0.01428 73rd percentileScored 2026-11-07
Fix Fixed doorkeeper (RubyGems): 4.2.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—doorkeeper (RubyGems)2.1.0 to before 4.2.64.2.6Patch availableGHSA-hwhh-2fwm-cfgw
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • doorkeeper (RubyGems) Vendor— Affected 2.1.0 to before 4.2.6 Fixed in 4.2.6 Patch available GHSA-hwhh-2fwm-cfgw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:*2.1.0 – 4.2.5VulnerableDoorkeeper Project
  • cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:* Versions 2.1.0 – 4.2.5 Vulnerable ·Doorkeeper Project

Remediation

  • Fix · GHSA-hwhh-2fwm-cfgw doorkeeper (RubyGems) Fixed in 4.2.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1000088
  2. 2026-10-03 Alias added: GHSA-hwhh-2fwm-cfgw

References

  • TI-2023-17082 Doorkeeper Improper Authentication vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2016-05635 The Doorkeeper gem before 4.2.0 for Ruby might allow remote attackers to conduct replay… CVSS 3.0CRITICAL 9.1
  • TI-2020-08208 Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that… CVSS 3.1HIGH 7.5
  • TI-2018-15860 Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in… CVSS 3.0HIGH 7.5
  • TI-2014-06759 Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote… CVSS 2.0MEDIUM 6.8

Sources