Read the docs
TI-2016-05635 Aliases CVE-2016-6582GHSA-3m6r-39p3-jq25

The Doorkeeper gem before 4.2.0 for Ruby might allow remote attackers to conduct replay…

Priority MEDIUM 47CWE-254Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

The Doorkeeper gem before 4.2.0 for Ruby might allow remote attackers to conduct replay attacks or revoke arbitrary tokens by leveraging failure to implement the OAuth 2.0 Token Revocation specification.

Why it matters now

EPSS 0.04814 92nd percentileScored 2026-11-07
Fix Fixed doorkeeper (RubyGems): 4.2.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—doorkeeper (RubyGems)before 4.2.04.2.0Patch availableGHSA-3m6r-39p3-jq25
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • doorkeeper (RubyGems) Vendor— Affected before 4.2.0 Fixed in 4.2.0 Patch available GHSA-3m6r-39p3-jq25

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:*up to 4.1.0VulnerableDoorkeeper Project
  • cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:ruby:*:* Versions up to 4.1.0 Vulnerable ·Doorkeeper Project

Remediation

  • Fix · GHSA-3m6r-39p3-jq25 doorkeeper (RubyGems) Fixed in 4.2.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2016-6582
  2. 2026-10-03 Alias added: GHSA-3m6r-39p3-jq25

References

  • TI-2023-17082 Doorkeeper Improper Authentication vulnerability CVSS 3.1MEDIUM 6.5
  • TI-2020-08208 Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that… CVSS 3.1HIGH 7.5
  • TI-2018-15860 Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in… CVSS 3.0HIGH 7.5
  • TI-2014-06759 Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote… CVSS 2.0MEDIUM 6.8
  • TI-2018-15743 Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS)… CVSS 3.0MEDIUM 6.1

Sources