Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in…
Priority LOW 36CWE-732Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in Token revocation API's authorized method that can result in Access tokens are not revoked for public OAuth apps, leaking access until expiry.
Why it matters now
EPSS 0.01553 75th percentileScored 2026-11-07
Fix Fixed doorkeeper (RubyGems): 4.4.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | doorkeeper (RubyGems) | 4.2.0 to before 4.4.0 | 4.4.0 | Patch available | GHSA-694m-jhr9-pf77 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- doorkeeper (RubyGems) Vendor— Affected 4.2.0 to before 4.4.0 Fixed in 4.4.0 Patch available GHSA-694m-jhr9-pf77
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:*:*:* | up to 4.2.0 | Vulnerable | Doorkeeper Project |
- cpe:2.3:a:doorkeeper_project:doorkeeper:*:*:*:*:*:*:*:* Versions up to 4.2.0 Vulnerable ·Doorkeeper Project
Remediation
- Fix · GHSA-694m-jhr9-pf77 doorkeeper (RubyGems) Fixed in 4.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1000211
- 2026-10-03 Alias added: GHSA-694m-jhr9-pf77
References
More Doorkeeper Project Doorkeeper vulnerabilities
- TI-2023-17082 Doorkeeper Improper Authentication vulnerability CVSS 3.1MEDIUM 6.5
- TI-2016-05635 The Doorkeeper gem before 4.2.0 for Ruby might allow remote attackers to conduct replay… CVSS 3.0CRITICAL 9.1
- TI-2020-08208 Doorkeeper version 5.0.0 and later contains an information disclosure vulnerability that… CVSS 3.1HIGH 7.5
- TI-2014-06759 Cross-site request forgery (CSRF) vulnerability in doorkeeper before 1.4.1 allows remote… CVSS 2.0MEDIUM 6.8
- TI-2018-15743 Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS)… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2018-1000211 · CVE Program
- CVE-2018-1000211 · NVD
- FIRST EPSS
- GHSA-694m-jhr9-pf77 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences