Ansible before 1.9.2 does not verify that the server hostname matches a domain name in…
Priority LOW 22CWE-345Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-345.
Summary
Ansible before 1.9.2 does not verify that the server hostname matches a domain name in the subject's Common Name (CN) or subjectAltName field of the X.509 certificate, which allows man-in-the-middle attackers to spoof SSL servers via an arbitrary valid certificate.
Why it matters now
EPSS 0.00941 61st percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.9.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ansible (PyPI) | before 1.9.2 | 1.9.2 | Patch available | GHSA-w64c-pxjj-h866 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 1.9.2 Fixed in 1.9.2 Patch available GHSA-w64c-pxjj-h866
Remediation
- Fix · GHSA-w64c-pxjj-h866 ansible (PyPI) Fixed in 1.9.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat OpenShift Enterprise 3
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat Quickstart Cloud Installer 1
- Red Hat Storage 3
- Red Hat Storage Console 2
Timeline
- 2026-10-02 Threatist record created from CVE-2015-3908
- 2026-10-03 Alias added: GHSA-w64c-pxjj-h866
References
Advisory 5
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-3908 · CVE Program
- CVE-2015-3908 · NVD
- FIRST EPSS
- GHSA-w64c-pxjj-h866 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-3908 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences