The chroot, jail, and zone connection plugins in ansible before 1.9.2 allow local users…
Priority LOW 34CWE-59Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The chroot, jail, and zone connection plugins in ansible before 1.9.2 allow local users to escape a restricted environment via a symlink attack.
Why it matters now
EPSS 0.00443 38th percentileScored 2026-11-07
Fix Fixed ansible (PyPI): 1.9.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | ansible (PyPI) | before 1.9.2 | 1.9.2 | Patch available | GHSA-wwwh-47wp-m522 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 1.9.2 Fixed in 1.9.2 Patch available GHSA-wwwh-47wp-m522
Remediation
- Fix · GHSA-wwwh-47wp-m522 ansible (PyPI) Fixed in 1.9.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat OpenShift Enterprise 3
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat Quickstart Cloud Installer 1
- Red Hat Storage 3
- Red Hat Storage Console 2
Timeline
- 2026-10-02 Threatist record created from CVE-2015-6240
- 2026-10-03 Alias added: GHSA-wwwh-47wp-m522
References
Patch 2
Advisory 3
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2015-6240 · CVE Program
- CVE-2015-6240 · NVD
- FIRST EPSS
- GHSA-wwwh-47wp-m522 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-6240 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences