Watu Quiz Plugin Exam exam.php watu_exams sql injection
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
A vulnerability was found in Watu Quiz Plugin up to 2.6.7 on WordPress. It has been rated as critical. This issue affects the function watu_exams of the file controllers/exam.php of the component Exam Handler. The manipulation of the argument quiz leads to sql injection. The attack may be initiated remotely. Upgrading to version 2.6.8 is able to address this issue. The patch is named bf42e7cfd819a3e76cf3e1465697e89f4830590c. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-230651.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Watu Quiz Plugin | 2.6.0; 2.6.1; 2.6.2; 2.6.3; 2.6.4; 2.6.5; 2.6.6; 2.6.7 | — | No fix listed | CNA |
- Watu Quiz Plugin Vendor— Affected 2.6.0; 2.6.1; 2.6.2; 2.6.3; 2.6.4; 2.6.5; 2.6.6; 2.6.7 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2015-10111
- 2026-10-03 Alias added: GHSA-5fj5-hp4f-cw5m
More prasunsen Watu Quiz vulnerabilities
- TI-2023-00405 Watu Quiz < 3.3.8.2 - Reflected XSS CVSS 3.1HIGH 7.5
- TI-2024-02456 Watu Quiz < 3.4.1.2 - Author+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2023-00406 Watu Quiz < 3.3.8.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2024-35990 WordPress Watu Quiz plugin <= 3.4.1.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-28994 WordPress Watu Quiz plugin <= 3.4.3 - SQL Injection Vulnerability CVSS 3.1HIGH 7.6
- TI-2025-22114 WordPress Watu Quiz plugin <= 3.4.2 - Reflected Cross Site Scripting (XSS) Vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2015-10111 · CVE Program
- CVE-2015-10111 · NVD
- FIRST EPSS
- GHSA-5fj5-hp4f-cw5m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences