Watu Quiz < 3.3.8.2 - Reflected XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Watu Quiz WordPress plugin before 3.3.8.2 does not sanitise and escape a parameter before outputting it back in the page, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Watu Quiz | before 3.3.8.2 | 3.3.8.2 | Patch available | CNA |
- Watu Quiz VendorUnknown Affected before 3.3.8.2 Fixed in 3.3.8.2 Patch available CNA
Remediation
- Fix · CNA Watu Quiz (Unknown) Fixed in 3.3.8.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Watu Quiz 3.3.8.2
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2023-00406 Watu Quiz < 3.3.8.3 - Admin+ Stored XSSPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0428
- 2026-10-03 Alias added: GHSA-3hmj-jp49-3cjx
- 2026-10-26 EPSS moved to the 50th–90th percentile
References
More prasunsen Watu Quiz vulnerabilities
- TI-2024-02456 Watu Quiz < 3.4.1.2 - Author+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2023-00406 Watu Quiz < 3.3.8.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2015-08039 Watu Quiz Plugin Exam exam.php watu_exams sql injection CVSS 3.1CRITICAL 9.8
- TI-2024-35990 WordPress Watu Quiz plugin <= 3.4.1.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-28994 WordPress Watu Quiz plugin <= 3.4.3 - SQL Injection Vulnerability CVSS 3.1HIGH 7.6
- TI-2025-22114 WordPress Watu Quiz plugin <= 3.4.2 - Reflected Cross Site Scripting (XSS) Vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2023-0428 · CVE Program
- CVE-2023-0428 · NVD
- FIRST EPSS
- GHSA-3hmj-jp49-3cjx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences