Watu Quiz < 3.4.1.2 - Author+ Stored XSS
Priority MEDIUM 63CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The Watu Quiz WordPress plugin before 3.4.1.2 does not sanitise and escape some of its settings, which could allow users such as authors (if they've been authorized by admins) to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00394 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Watu Quiz (Unknown): 3.4.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Watu Quiz | before 3.4.1.2 | 3.4.1.2 | Patch available | CNA |
- Watu Quiz VendorUnknown Affected before 3.4.1.2 Fixed in 3.4.1.2 Patch available CNA
Remediation
- Fix · CNA Watu Quiz (Unknown) Fixed in 3.4.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2024-2640
- 2026-10-03 Alias added: GHSA-c7x7-vc85-8vmc
References
More prasunsen Watu Quiz vulnerabilities
- TI-2023-00405 Watu Quiz < 3.3.8.2 - Reflected XSS CVSS 3.1HIGH 7.5
- TI-2023-00406 Watu Quiz < 3.3.8.3 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2015-08039 Watu Quiz Plugin Exam exam.php watu_exams sql injection CVSS 3.1CRITICAL 9.8
- TI-2024-35990 WordPress Watu Quiz plugin <= 3.4.1.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-28994 WordPress Watu Quiz plugin <= 3.4.3 - SQL Injection Vulnerability CVSS 3.1HIGH 7.6
- TI-2025-22114 WordPress Watu Quiz plugin <= 3.4.2 - Reflected Cross Site Scripting (XSS) Vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2024-2640 · CVE Program
- CVE-2024-2640 · NVD
- FIRST EPSS
- GHSA-c7x7-vc85-8vmc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences