Watu Quiz < 3.3.8.3 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Watu Quiz WordPress plugin before 3.3.8.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Watu Quiz | before 3.3.8.2 | 3.3.8.2 | Patch available | CNA |
- Watu Quiz VendorUnknown Affected before 3.3.8.2 Fixed in 3.3.8.2 Patch available CNA
Remediation
- Fix · CNA Watu Quiz (Unknown) Fixed in 3.3.8.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Watu Quiz 3.3.8.2
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2023-00405 Watu Quiz < 3.3.8.2 - Reflected XSSPriority HIGH 68
Timeline
- 2026-10-02 Threatist record created from CVE-2023-0429
- 2026-10-03 Alias added: GHSA-fr8p-9xx7-rw2c
References
More prasunsen Watu Quiz vulnerabilities
- TI-2023-00405 Watu Quiz < 3.3.8.2 - Reflected XSS CVSS 3.1HIGH 7.5
- TI-2024-02456 Watu Quiz < 3.4.1.2 - Author+ Stored XSS CVSS 3.1MEDIUM 6.8
- TI-2015-08039 Watu Quiz Plugin Exam exam.php watu_exams sql injection CVSS 3.1CRITICAL 9.8
- TI-2024-35990 WordPress Watu Quiz plugin <= 3.4.1.2 - SQL Injection vulnerability CVSS 3.1HIGH 8.8
- TI-2025-28994 WordPress Watu Quiz plugin <= 3.4.3 - SQL Injection Vulnerability CVSS 3.1HIGH 7.6
- TI-2025-22114 WordPress Watu Quiz plugin <= 3.4.2 - Reflected Cross Site Scripting (XSS) Vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2023-0429 · CVE Program
- CVE-2023-0429 · NVD
- FIRST EPSS
- GHSA-fr8p-9xx7-rw2c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences