Cross-site scripting (XSS) vulnerability in the format function in…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the format function in libraries/sql-parser/src/Utils/Error.php in the SQL parser in phpMyAdmin 4.5.x before 4.5.5.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted query.
Why it matters now
EPSS 0.01712 77th percentileScored 2026-11-07
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.5.5.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | 4.5 to before 4.5.5.1 | 4.5.5.1 | Patch available | GHSA-7rf8-9r8f-qf59 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.5 to before 4.5.5.1 Fixed in 4.5.5.1 Patch available GHSA-7rf8-9r8f-qf59
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:*:*:*:*:*:*:* | 4.5.0 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:beta1:*:*:*:*:*:* | 4.5.0 beta1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:beta2:*:*:*:*:*:* | 4.5.0 beta2 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:rc1:*:*:*:*:*:* | 4.5.0 rc1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.1:*:*:*:*:*:*:* | 4.5.0.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.2:*:*:*:*:*:*:* | 4.5.0.2 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.1:*:*:*:*:*:*:* | 4.5.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.2:*:*:*:*:*:*:* | 4.5.2 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.3:*:*:*:*:*:*:* | 4.5.3 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.3.1:*:*:*:*:*:*:* | 4.5.3.1 | Vulnerable | phpMyAdmin |
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:*:*:*:*:*:*:* Versions 4.5.0 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:beta1:*:*:*:*:*:* Versions 4.5.0 beta1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:beta2:*:*:*:*:*:* Versions 4.5.0 beta2 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0:rc1:*:*:*:*:*:* Versions 4.5.0 rc1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.1:*:*:*:*:*:*:* Versions 4.5.0.1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.0.2:*:*:*:*:*:*:* Versions 4.5.0.2 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.1:*:*:*:*:*:*:* Versions 4.5.1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.2:*:*:*:*:*:*:* Versions 4.5.2 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.3:*:*:*:*:*:*:* Versions 4.5.3 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.3.1:*:*:*:*:*:*:* Versions 4.5.3.1 Vulnerable ·phpMyAdmin
Show 3 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.4:*:*:*:*:*:*:* | 4.5.4 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.4.1:*:*:*:*:*:*:* | 4.5.4.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.5:*:*:*:*:*:*:* | 4.5.5 | Vulnerable | phpMyAdmin |
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.4:*:*:*:*:*:*:* Versions 4.5.4 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.4.1:*:*:*:*:*:*:* Versions 4.5.4.1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.5.5:*:*:*:*:*:*:* Versions 4.5.5 Vulnerable ·phpMyAdmin
Remediation
- Fix · GHSA-7rf8-9r8f-qf59 phpmyadmin/phpmyadmin (Packagist) Fixed in 4.5.5.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-2559
- 2026-10-03 Alias added: GHSA-7rf8-9r8f-qf59
References
Advisory 4
More Phpmyadmin vulnerabilities
- TI-2009-01092 Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-09056 An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can… CVSS 3.1HIGH 8.8
- TI-2020-14341 SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in… CVSS 3.1CRITICAL 9.8
- TI-2016-04978 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not… CVSS 3.0CRITICAL 9.8
- TI-2020-16362 An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before… CVSS 3.1CRITICAL 9.8
- TI-2012-04350 phpMyAdmin 3.5.2.2, as distributed by the cdnetworks-kr-1 mirror during an unspecified… CVSS 2.0HIGH 7.5
Sources
- CVE-2016-2559 · CVE Program
- CVE-2016-2559 · NVD
- FIRST EPSS
- GHSA-7rf8-9r8f-qf59 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-2559 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences