XSS issues were discovered in phpMyAdmin.
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
XSS issues were discovered in phpMyAdmin. This affects the database privilege check and the "Remove partitioning" functionality. Specially crafted database names can trigger the XSS attack. All 4.6.x versions (prior to 4.6.4) are affected.
Why it matters now
EPSS 0.0128 70th percentileScored 2026-11-07
Fix Fixed phpmyadmin/phpmyadmin (Packagist): 4.6.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmyadmin/phpmyadmin (Packagist) | 4.6 to before 4.6.4 | 4.6.4 | Patch available | GHSA-jfmj-27fp-qp67 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 4.6 to before 4.6.4 Fixed in 4.6.4 Patch available GHSA-jfmj-27fp-qp67
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.0:*:*:*:*:*:*:* | 4.6.0 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.0:alpha1:*:*:*:*:*:* | 4.6.0 alpha1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.0:rc1:*:*:*:*:*:* | 4.6.0 rc1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.0:rc2:*:*:*:*:*:* | 4.6.0 rc2 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.1:*:*:*:*:*:*:* | 4.6.1 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.2:*:*:*:*:*:*:* | 4.6.2 | Vulnerable | phpMyAdmin |
| cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.3:*:*:*:*:*:*:* | 4.6.3 | Vulnerable | phpMyAdmin |
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.0:*:*:*:*:*:*:* Versions 4.6.0 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.0:alpha1:*:*:*:*:*:* Versions 4.6.0 alpha1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.0:rc1:*:*:*:*:*:* Versions 4.6.0 rc1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.0:rc2:*:*:*:*:*:* Versions 4.6.0 rc2 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.1:*:*:*:*:*:*:* Versions 4.6.1 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.2:*:*:*:*:*:*:* Versions 4.6.2 Vulnerable ·phpMyAdmin
- cpe:2.3:a:phpmyadmin:phpmyadmin:4.6.3:*:*:*:*:*:*:* Versions 4.6.3 Vulnerable ·phpMyAdmin
Remediation
- Fix · GHSA-jfmj-27fp-qp67 phpmyadmin/phpmyadmin (Packagist) Fixed in 4.6.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2016-6608
- 2026-10-03 Alias added: GHSA-jfmj-27fp-qp67
References
More Phpmyadmin vulnerabilities
- TI-2009-01092 Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and… KEVCVSS 3.1CRITICAL 9.8
- TI-2018-09056 An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can… CVSS 3.1HIGH 8.8
- TI-2020-14341 SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in… CVSS 3.1CRITICAL 9.8
- TI-2016-04978 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not… CVSS 3.0CRITICAL 9.8
- TI-2020-16362 An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before… CVSS 3.1CRITICAL 9.8
- TI-2012-04350 phpMyAdmin 3.5.2.2, as distributed by the cdnetworks-kr-1 mirror during an unspecified… CVSS 2.0HIGH 7.5
Sources
- CVE-2016-6608 · CVE Program
- CVE-2016-6608 · NVD
- FIRST EPSS
- GHSA-jfmj-27fp-qp67 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-6608 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences