A flaw was found in Ansible before version 2.2.0.
Priority LOW 38CWE-358Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.
Why it matters now
EPSS 0.02458 84th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed ansible (PyPI): 2.2.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Red Hat | Ansible | 2.2.0 | — | No fix listed | CNA |
| — | ansible (PyPI) | before 2.2.0.0 | 2.2.0.0 | Patch available | GHSA-cmwx-9m2h-x7v4 |
- Ansible VendorRed Hat Affected 2.2.0 Fixed in — No fix listed CNA
- ansible (PyPI) Vendor— Affected before 2.2.0.0 Fixed in 2.2.0.0 Patch available GHSA-cmwx-9m2h-x7v4
Remediation
- Fix · GHSA-cmwx-9m2h-x7v4 ansible (PyPI) Fixed in 2.2.0.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat OpenShift Enterprise 3
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat Quickstart Cloud Installer 1
- Red Hat Storage 3
- Red Hat Storage Console 2
Timeline
- 2026-10-02 Threatist record created from CVE-2016-8614
- 2026-10-03 Alias added: GHSA-cmwx-9m2h-x7v4
References
Exploit 2
Advisory 4
Other 5
- https://github.com/ansible/ansible-modules-core/commit/1182d1f0b76d56f3667e27987a10b9ec8f03357d
- https://github.com/ansible/ansible-modules-core/commit/66d47c8149d84e52f64b7c4d1f340d45dca94d9c
- https://github.com/ansible/ansible
- https://github.com/pypa/advisory-database/tree/main/vulns/ansible/PYSEC-2018-37.yaml
- https://web.archive.org/web/20200227214450/https://www.securityfocus.com/bid/94108
More Red Hat Ansible vulnerabilities
- TI-2016-07808 Improper input validation in Ansible CVSS 3.1HIGH 8.1
- TI-2014-03853 Injection in Ansible CVSS 3.1CRITICAL 9.8
- TI-2014-03839 The safe_eval function in Ansible before 1.5.4 does not properly restrict the code… CVSS 3.1CRITICAL 9.8
- TI-2017-05191 Sensitive information in log files in Red Hat ansible CVSS 3.1CRITICAL 9.8
- TI-2014-04077 Multiple argument injection vulnerabilities in Ansible before 1.6.7 allow remote… CVSS 3.1CRITICAL 9.8
- TI-2014-04076 Ansible before 1.6.7 does not prevent inventory data with "{{" and "lookup" substrings… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2016-8614 · CVE Program
- CVE-2016-8614 · NVD
- FIRST EPSS
- GHSA-cmwx-9m2h-x7v4 · GitHub Advisory Database · CC BY 4.0
- CVE-2016-8614 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences