PHPMailer 5.2.23 has XSS in the "From Email Address" and "To Email Address" fields of code_generator.php.
Priority LOW 32CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
PHPMailer 5.2.23 has XSS in the "From Email Address" and "To Email Address" fields of code_generator.php.
Why it matters now
EPSS 0.024 84th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpmailer/phpmailer (Packagist): 5.2.24
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpmailer/phpmailer (Packagist) | 5.0.0 to before 5.2.24 | 5.2.24 | Patch available | GHSA-58mj-pw57-4vm2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpmailer/phpmailer (Packagist) Vendor— Affected 5.0.0 to before 5.2.24 Fixed in 5.2.24 Patch available GHSA-58mj-pw57-4vm2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpmailer_project:phpmailer:5.2.23:*:*:*:*:*:*:* | 5.2.23 | Vulnerable | Phpmailer Project |
- cpe:2.3:a:phpmailer_project:phpmailer:5.2.23:*:*:*:*:*:*:* Versions 5.2.23 Vulnerable ·Phpmailer Project
Remediation
- Fix · GHSA-58mj-pw57-4vm2 phpmailer/phpmailer (Packagist) Fixed in 5.2.24 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-11503
- 2026-10-03 Alias added: GHSA-58mj-pw57-4vm2
References
More Phpmailer Project Phpmailer vulnerabilities
- TI-2016-08118 The mailSend function in the isMail transport in PHPMailer before 5.2.18 might allow… KEVCVSS 3.1CRITICAL 9.8
- TI-2016-08129 The isMail transport in PHPMailer before 5.2.20 might allow remote attackers to pass… CVSS 3.1CRITICAL 9.8
- TI-2020-18609 PHPMailer 6.1.8 through 6.4.0 allows object injection through Phar Deserialization via… CVSS 3.1CRITICAL 9.8
- TI-2018-13680 PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack. CVSS 3.1HIGH 8.8
- TI-2021-13570 PHPMailer before 6.5.0 on Windows allows remote code execution if lang_path is untrusted data and has a UNC pathname. CVSS 3.1HIGH 8.1
- TI-2021-02549 Inclusion of Functionality from Untrusted Control Sphere in PHPMailer/PHPMailer CVSS 3.1HIGH 8.1
Sources
- CVE-2017-11503 · CVE Program
- CVE-2017-11503 · NVD
- FIRST EPSS
- GHSA-58mj-pw57-4vm2 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-11503 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences