The installation process in LibreNMS before 2017-08-18 allows remote attackers to read…
Priority LOW 31CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
The installation process in LibreNMS before 2017-08-18 allows remote attackers to read arbitrary files, related to html/install.php.
Why it matters now
EPSS 0.02246 82nd percentileScored 2026-11-07
Fix Fixed librenms/librenms (Packagist): 1.31
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | librenms/librenms (Packagist) | before 1.31 | 1.31 | Patch available | GHSA-4ccx-wjqp-5fww |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- librenms/librenms (Packagist) Vendor— Affected before 1.31 Fixed in 1.31 Patch available GHSA-4ccx-wjqp-5fww
Remediation
- Fix · GHSA-4ccx-wjqp-5fww librenms/librenms (Packagist) Fixed in 1.31 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-16759
- 2026-10-03 Alias added: GHSA-4ccx-wjqp-5fww
References
Patch 2
Advisory 3
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2017-16759 · CVE Program
- CVE-2017-16759 · NVD
- FIRST EPSS
- GHSA-4ccx-wjqp-5fww · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences