OS command injection in librenms
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
LibreNMS versions before 26.3.0 are affected by an authenticated remote code execution vulnerability by abusing the Binary Locations config and the Netcommand feature. Successful exploitation requires administrative privileges. Exploitation could result in compromise of the underlying web server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms | before 26.3.0 | 26.3.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | 1.48 to before 26.3.0 | 26.3.0 | Patch available | GHSA-pr3g-phhr-h8fh |
- librenms Vendorlibrenms Affected before 26.3.0 Fixed in 26.3.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected 1.48 to before 26.3.0 Fixed in 26.3.0 Patch available GHSA-pr3g-phhr-h8fh
Remediation
- Fix · CNA librenms (librenms) Fixed in 26.3.0
- Fix · GHSA-pr3g-phhr-h8fh librenms/librenms (Packagist) Fixed in 26.3.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
librenms 26.3.0
2 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM
Other records, highest priority first
- TI-2026-02335 Cross-site scripting in librenmsPriority MEDIUM 54
Timeline
- 2026-10-02 Threatist record created from CVE-2026-6204
- 2026-10-03 Alias added: GHSA-pr3g-phhr-h8fh
- 2026-10-25 EPSS moved to the 90th–95th percentile
References
Advisory 2
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
- TI-2023-25228 Rate limiting Bypass on login page in libreNMS CVSS 3.1HIGH 7.5
Sources
- CVE-2026-6204 · CVE Program
- CVE-2026-6204 · NVD
- FIRST EPSS
- GHSA-pr3g-phhr-h8fh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences