Deserialization of Untrusted Data in librenms/librenms
Priority HIGH 73CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
Deserialization of Untrusted Data in GitHub repository librenms/librenms prior to 22.10.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00951 61st percentileScored 2026-11-07
Fix Fixed librenms/librenms (librenms): 22.10.0librenms/librenms (Packagist): 22.10.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| librenms | librenms/librenms | before 22.10.0 | 22.10.0 | Patch available | CNA |
| — | librenms/librenms (Packagist) | before 22.10.0 | 22.10.0 | Patch available | GHSA-cv9g-h8mm-xx5h |
- librenms/librenms Vendorlibrenms Affected before 22.10.0 Fixed in 22.10.0 Patch available CNA
- librenms/librenms (Packagist) Vendor— Affected before 22.10.0 Fixed in 22.10.0 Patch available GHSA-cv9g-h8mm-xx5h
Remediation
- Fix · CNA librenms/librenms (librenms) Fixed in 22.10.0
- Fix · GHSA-cv9g-h8mm-xx5h librenms/librenms (Packagist) Fixed in 22.10.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
librenms/librenms 22.10.0
8 records Highest priority Priority HIGH 5 HIGH, 3 MEDIUM
Other records, highest priority first
- TI-2022-03735 Insufficient Session Expiration in librenms/librenmsPriority HIGH 75
- TI-2022-03732 Cross-site Scripting (XSS) - Stored in librenms/librenmsPriority HIGH 68
- TI-2022-03278 Cross-site Scripting (XSS) - Stored in librenms/librenmsPriority HIGH 68
Timeline
- 2026-10-02 Threatist record created from CVE-2022-3525
- 2026-10-03 Alias added: GHSA-cv9g-h8mm-xx5h
References
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
- TI-2023-25228 Rate limiting Bypass on login page in libreNMS CVSS 3.1HIGH 7.5
Sources
- CVE-2022-3525 · CVE Program
- CVE-2022-3525 · NVD
- FIRST EPSS
- GHSA-cv9g-h8mm-xx5h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences