LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command…
Priority HIGH 72CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command injection involving AboutController.php's index(), SettingsController.php's update(), and PollDevice.php's initRrdDirectory().
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.07176 94th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed librenms/librenms (Packagist): 24.10.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | librenms/librenms (Packagist) | before 24.10.0 | 24.10.0 | Patch available | GHSA-x645-6pf9-xwxw |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- librenms/librenms (Packagist) Vendor— Affected before 24.10.0 Fixed in 24.10.0 Patch available GHSA-x645-6pf9-xwxw
Remediation
- Fix · GHSA-x645-6pf9-xwxw librenms/librenms (Packagist) Fixed in 24.10.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-51092
- 2026-10-03 Alias added: GHSA-x645-6pf9-xwxw
References
Exploit 2
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2023-25228 Rate limiting Bypass on login page in libreNMS CVSS 3.1HIGH 7.5
Sources
- CVE-2024-51092 · CVE Program
- CVE-2024-51092 · NVD
- FIRST EPSS
- GHSA-x645-6pf9-xwxw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences