Read the docs
TI-2018-03988 Aliases CVE-2018-5478GHSA-mpg7-2rx9-h5qp

Contao 3.x before 3.5.32 allows XSS via the unsubscribe module in the frontend newsletter extension.

Priority LOW 27CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

Contao 3.x before 3.5.32 allows XSS via the unsubscribe module in the frontend newsletter extension.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00415 36th percentileScored 2026-11-07
Fix Fixed contao/core (Packagist): 3.5.32

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—contao/core (Packagist)3.0.0 to before 3.5.323.5.32Patch availableGHSA-mpg7-2rx9-h5qp
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • contao/core (Packagist) Vendor— Affected 3.0.0 to before 3.5.32 Fixed in 3.5.32 Patch available GHSA-mpg7-2rx9-h5qp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:*3.0.0 to before 3.5.32Vulnerablecontao
  • cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 3.0.0 to before 3.5.32 Vulnerable ·contao

Remediation

  • Fix · GHSA-mpg7-2rx9-h5qp contao/core (Packagist) Fixed in 3.5.32 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-5478
  2. 2026-10-03 Alias added: GHSA-mpg7-2rx9-h5qp

References

  • TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
  • TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
  • TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
  • TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
  • TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
  • TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
See all 31 →

Sources