Remote command execution through file upload in contao/core-bundle
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
Contao is an Open Source CMS. In affected versions a back end user with access to the file manager can upload malicious files and execute them on the server. Users are advised to update to Contao 4.13.49, 5.3.15 or 5.4.3. Users unable to update are advised to configure their web server so it does not execute PHP files and other scripts in the Contao file upload directory.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| contao | contao | 4.0.0 to before 4.13.49; 5.0.0 to before 5.3.15; 5.4.0 to before 5.4.3 | 4.13.49, 5.3.15, 5.4.3 | Patch available | CNA |
| — | contao/core-bundle (Packagist) | 4.0.0 to before 4.13.49 | 4.13.49 | Patch available | GHSA-vm6r-j788-hjh5 |
| — | contao/core-bundle (Packagist) | 5.0.0 to before 5.3.15 | 5.3.15 | Patch available | GHSA-vm6r-j788-hjh5 |
| — | contao/core-bundle (Packagist) | 5.4.0 to before 5.4.3 | 5.4.3 | Patch available | GHSA-vm6r-j788-hjh5 |
- contao Vendorcontao Affected 4.0.0 to before 4.13.49; 5.0.0 to before 5.3.15; 5.4.0 to before 5.4.3 Fixed in 4.13.49, 5.3.15, 5.4.3 Patch available CNA
- contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.13.49 Fixed in 4.13.49 Patch available GHSA-vm6r-j788-hjh5
- contao/core-bundle (Packagist) Vendor— Affected 5.0.0 to before 5.3.15 Fixed in 5.3.15 Patch available GHSA-vm6r-j788-hjh5
- contao/core-bundle (Packagist) Vendor— Affected 5.4.0 to before 5.4.3 Fixed in 5.4.3 Patch available GHSA-vm6r-j788-hjh5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* | 4.0.0 to before 4.13.49; 5.0.0 to before 5.3.15; 5.4.0 to before 5.4.3 | Vulnerable | contao |
- cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.13.49; 5.0.0 to before 5.3.15; 5.4.0 to before 5.4.3 Vulnerable ·contao
Remediation
- Fix · CNA contao (contao) Fixed in 4.13.49, 5.3.15, 5.4.3
- Fix · GHSA-vm6r-j788-hjh5 contao/core-bundle (Packagist) Fixed in 4.13.49 Advisory →
- Fix · GHSA-vm6r-j788-hjh5 contao/core-bundle (Packagist) Fixed in 5.3.15 Advisory →
- Fix · GHSA-vm6r-j788-hjh5 contao/core-bundle (Packagist) Fixed in 5.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45398
- 2026-10-03 Alias added: GHSA-vm6r-j788-hjh5
References
Advisory 3
More Contao vulnerabilities
- TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
- TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
- TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
- TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
- TI-2019-14229 Contao 4.0 through 4.8.5 allows PHP local file inclusion. CVSS 3.1HIGH 8.8
Sources
- CVE-2024-45398 · CVE Program
- CVE-2024-45398 · NVD
- FIRST EPSS
- GHSA-vm6r-j788-hjh5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences