Read the docs
TI-2018-05493 Aliases CVE-2018-7600GHSA-7fh9-933g-885p

Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6…

Priority CRITICAL 100Exploited in the wildCWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub.

Summary

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

Why it matters now

Exploitation Active In CISA KEV since 2021-11-03CISA due date 2022-05-03Known ransomware use
EPSS 0.99991 99th percentileScored 2026-11-07
Public exploit Yes 4 exploit referencesTagged by the CNA and NVD
Fix Fixed drupal/core (Packagist): 7.58, 8.3.9, 8.4.6 +1drupal/drupal (Packagist): 7.58, 8.3.9, 8.4.6 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1—No fix listedCNA
—drupal/core (Packagist)7.0 to before 7.587.58Patch availableGHSA-7fh9-933g-885p
—drupal/core (Packagist)8.0 to before 8.3.98.3.9Patch availableGHSA-7fh9-933g-885p
—drupal/core (Packagist)8.4.0 to before 8.4.68.4.6Patch availableGHSA-7fh9-933g-885p
—drupal/core (Packagist)8.5.0 to before 8.5.18.5.1Patch availableGHSA-7fh9-933g-885p
—drupal/drupal (Packagist)7.0 to before 7.587.58Patch availableGHSA-7fh9-933g-885p
—drupal/drupal (Packagist)8.0 to before 8.3.98.3.9Patch availableGHSA-7fh9-933g-885p
—drupal/drupal (Packagist)8.4 to before 8.4.68.4.6Patch availableGHSA-7fh9-933g-885p
—drupal/drupal (Packagist)8.5 to before 8.5.18.5.1Patch availableGHSA-7fh9-933g-885p
  • Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 Vendor— Affected Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 Fixed in — No fix listed CNA
  • drupal/core (Packagist) Vendor— Affected 7.0 to before 7.58 Fixed in 7.58 Patch available GHSA-7fh9-933g-885p
  • drupal/core (Packagist) Vendor— Affected 8.0 to before 8.3.9 Fixed in 8.3.9 Patch available GHSA-7fh9-933g-885p
  • drupal/core (Packagist) Vendor— Affected 8.4.0 to before 8.4.6 Fixed in 8.4.6 Patch available GHSA-7fh9-933g-885p
  • drupal/core (Packagist) Vendor— Affected 8.5.0 to before 8.5.1 Fixed in 8.5.1 Patch available GHSA-7fh9-933g-885p
  • drupal/drupal (Packagist) Vendor— Affected 7.0 to before 7.58 Fixed in 7.58 Patch available GHSA-7fh9-933g-885p
  • drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.3.9 Fixed in 8.3.9 Patch available GHSA-7fh9-933g-885p
  • drupal/drupal (Packagist) Vendor— Affected 8.4 to before 8.4.6 Fixed in 8.4.6 Patch available GHSA-7fh9-933g-885p
  • drupal/drupal (Packagist) Vendor— Affected 8.5 to before 8.5.1 Fixed in 8.5.1 Patch available GHSA-7fh9-933g-885p

CPE configurations NVD · 4

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*up to 7.57; 8.0.0 to before 8.3.9; 8.4.0 to before 8.4.6; 8.5.0 to before 8.5.1VulnerableDrupal
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*7.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*8.0VulnerableDebian
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions up to 7.57; 8.0.0 to before 8.3.9; 8.4.0 to before 8.4.6; 8.5.0 to before 8.5.1 Vulnerable ·Drupal
  • cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian

Remediation

  • Fix · GHSA-7fh9-933g-885p drupal/core (Packagist) Fixed in 7.58 Advisory →
  • Fix · GHSA-7fh9-933g-885p drupal/core (Packagist) Fixed in 8.3.9 Advisory →
  • Fix · GHSA-7fh9-933g-885p drupal/core (Packagist) Fixed in 8.4.6 Advisory →
  • Fix · GHSA-7fh9-933g-885p drupal/core (Packagist) Fixed in 8.5.1 Advisory →
  • Fix · GHSA-7fh9-933g-885p drupal/drupal (Packagist) Fixed in 7.58 Advisory →
  • Fix · GHSA-7fh9-933g-885p drupal/drupal (Packagist) Fixed in 8.3.9 Advisory →
  • Fix · GHSA-7fh9-933g-885p drupal/drupal (Packagist) Fixed in 8.4.6 Advisory →
  • Fix · GHSA-7fh9-933g-885p drupal/drupal (Packagist) Fixed in 8.5.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2021-11-03 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2018-7600
  3. 2026-10-03 Alias added: GHSA-7fh9-933g-885p

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
  • TI-2020-18513 Tar.php in Archive_Tar through 1.4.11 allows write operations with Directory Traversal… KEVCVSS 3.1HIGH 7.5
See all 278 →

Sources