Read the docs
TI-2019-04505 Aliases CVE-2019-6340GHSA-3gx6-h57h-rm27

Drupal core - Highly critical - Remote Code Execution

Priority CRITICAL 94Exploited in the wildCWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

Why it matters now

Exploitation Active In CISA KEV since 2022-03-25CISA due date 2022-04-15
EPSS 0.92017 99th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by the CNA and NVD
Fix Fixed Drupal Core (Drupal): 8.5.11, 8.6.10drupal/core (Packagist): 8.6.10, 7.62.0, 8.5.11+1 more product

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Active
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
DrupalDrupal Core8.5 to before 8.5.11; 8.6 to before 8.6.108.5.11, 8.6.10Patch availableCNA
—drupal/core (Packagist)8.6.0 to before 8.6.108.6.10Patch availableGHSA-3gx6-h57h-rm27
—drupal/core (Packagist)7.0.0 to before 7.62.07.62.0Patch availableGHSA-3gx6-h57h-rm27
—drupal/core (Packagist)8.0.0 to before 8.5.118.5.11Patch availableGHSA-3gx6-h57h-rm27
—drupal/drupal (Packagist)7.0.0 to before 7.62.07.62.0Patch availableGHSA-3gx6-h57h-rm27
—drupal/drupal (Packagist)8.0.0 to before 8.5.118.5.11Patch availableGHSA-3gx6-h57h-rm27
—drupal/drupal (Packagist)8.6.0 to before 8.6.108.6.10Patch availableGHSA-3gx6-h57h-rm27
  • Drupal Core VendorDrupal Affected 8.5 to before 8.5.11; 8.6 to before 8.6.10 Fixed in 8.5.11, 8.6.10 Patch available CNA
  • drupal/core (Packagist) Vendor— Affected 8.6.0 to before 8.6.10 Fixed in 8.6.10 Patch available GHSA-3gx6-h57h-rm27
  • drupal/core (Packagist) Vendor— Affected 7.0.0 to before 7.62.0 Fixed in 7.62.0 Patch available GHSA-3gx6-h57h-rm27
  • drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.5.11 Fixed in 8.5.11 Patch available GHSA-3gx6-h57h-rm27
  • drupal/drupal (Packagist) Vendor— Affected 7.0.0 to before 7.62.0 Fixed in 7.62.0 Patch available GHSA-3gx6-h57h-rm27
  • drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.5.11 Fixed in 8.5.11 Patch available GHSA-3gx6-h57h-rm27
  • drupal/drupal (Packagist) Vendor— Affected 8.6.0 to before 8.6.10 Fixed in 8.6.10 Patch available GHSA-3gx6-h57h-rm27

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.5.0 to before 8.5.11; 8.6.0 to before 8.6.10VulnerableDrupal
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.5.0 to before 8.5.11; 8.6.0 to before 8.6.10 Vulnerable ·Drupal

Remediation

  • Fix · CNA Drupal Core (Drupal) Fixed in 8.5.11, 8.6.10
  • Fix · GHSA-3gx6-h57h-rm27 drupal/core (Packagist) Fixed in 8.6.10 Advisory →
  • Fix · GHSA-3gx6-h57h-rm27 drupal/core (Packagist) Fixed in 7.62.0 Advisory →
  • Fix · GHSA-3gx6-h57h-rm27 drupal/core (Packagist) Fixed in 8.5.11 Advisory →
  • Fix · GHSA-3gx6-h57h-rm27 drupal/drupal (Packagist) Fixed in 7.62.0 Advisory →
  • Fix · GHSA-3gx6-h57h-rm27 drupal/drupal (Packagist) Fixed in 8.5.11 Advisory →
  • Fix · GHSA-3gx6-h57h-rm27 drupal/drupal (Packagist) Fixed in 8.6.10 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2022-03-25 Added to CISA KEV
  2. 2026-10-02 Threatist record created from CVE-2019-6340
  3. 2026-10-03 Alias added: GHSA-3gx6-h57h-rm27

References

  • TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
  • TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
  • TI-2020-18513 Tar.php in Archive_Tar through 1.4.11 allows write operations with Directory Traversal… KEVCVSS 3.1HIGH 7.5
See all 278 →

Sources