Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
A remote code execution vulnerability exists within multiple subsystems of Drupal 7.x and 8.x. This potentially allows attackers to exploit multiple attack vectors on a Drupal site, which could result in the site being compromised. This vulnerability is related to Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-002. Both SA-CORE-2018-002 and this vulnerability are being exploited in the wild.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | core | before 7.59; before 8.5.3; before 8.4.8 | 7.59, 8.5.3, 8.4.8 | Patch available | CNA |
| — | drupal/core (Packagist) | 7.0 to before 7.59 | 7.59 | Patch available | GHSA-297x-j9pm-xjgg |
| — | drupal/core (Packagist) | 8.0 to before 8.4.8 | 8.4.8 | Patch available | GHSA-297x-j9pm-xjgg |
| — | drupal/core (Packagist) | 8.5 to before 8.5.3 | 8.5.3 | Patch available | GHSA-297x-j9pm-xjgg |
| — | drupal/drupal (Packagist) | 7.0 to before 7.59 | 7.59 | Patch available | GHSA-297x-j9pm-xjgg |
| — | drupal/drupal (Packagist) | 8.0 to before 8.4.8 | 8.4.8 | Patch available | GHSA-297x-j9pm-xjgg |
| — | drupal/drupal (Packagist) | 8.5 to before 8.5.3 | 8.5.3 | Patch available | GHSA-297x-j9pm-xjgg |
- core VendorDrupal Affected before 7.59; before 8.5.3; before 8.4.8 Fixed in 7.59, 8.5.3, 8.4.8 Patch available CNA
- drupal/core (Packagist) Vendor— Affected 7.0 to before 7.59 Fixed in 7.59 Patch available GHSA-297x-j9pm-xjgg
- drupal/core (Packagist) Vendor— Affected 8.0 to before 8.4.8 Fixed in 8.4.8 Patch available GHSA-297x-j9pm-xjgg
- drupal/core (Packagist) Vendor— Affected 8.5 to before 8.5.3 Fixed in 8.5.3 Patch available GHSA-297x-j9pm-xjgg
- drupal/drupal (Packagist) Vendor— Affected 7.0 to before 7.59 Fixed in 7.59 Patch available GHSA-297x-j9pm-xjgg
- drupal/drupal (Packagist) Vendor— Affected 8.0 to before 8.4.8 Fixed in 8.4.8 Patch available GHSA-297x-j9pm-xjgg
- drupal/drupal (Packagist) Vendor— Affected 8.5 to before 8.5.3 Fixed in 8.5.3 Patch available GHSA-297x-j9pm-xjgg
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 7.0 to before 7.59; 8.4.0 to before 8.4.8; 8.5.0 to before 8.5.3 | Vulnerable | Drupal |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.59; 8.4.0 to before 8.4.8; 8.5.0 to before 8.5.3 Vulnerable ·Drupal
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · CNA core (Drupal) Fixed in 7.59, 8.5.3, 8.4.8
- Fix · GHSA-297x-j9pm-xjgg drupal/core (Packagist) Fixed in 7.59 Advisory →
- Fix · GHSA-297x-j9pm-xjgg drupal/core (Packagist) Fixed in 8.4.8 Advisory →
- Fix · GHSA-297x-j9pm-xjgg drupal/core (Packagist) Fixed in 8.5.3 Advisory →
- Fix · GHSA-297x-j9pm-xjgg drupal/drupal (Packagist) Fixed in 7.59 Advisory →
- Fix · GHSA-297x-j9pm-xjgg drupal/drupal (Packagist) Fixed in 8.4.8 Advisory →
- Fix · GHSA-297x-j9pm-xjgg drupal/drupal (Packagist) Fixed in 8.5.3 Advisory →
Vendor assessments
Timeline
- 2022-04-13 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2018-7602
- 2026-10-03 Alias added: GHSA-297x-j9pm-xjgg
References
Advisory 3
Other 6
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2018-7602.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2018-7602.yaml
- https://github.com/drupal/core
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2018-7602
- https://www.exploit-db.com/exploits/44542
- https://www.exploit-db.com/exploits/44557
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
- TI-2020-18513 Tar.php in Archive_Tar through 1.4.11 allows write operations with Directory Traversal… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2018-7602 · CVE Program
- CVE-2018-7602 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-297x-j9pm-xjgg · GitHub Advisory Database · CC BY 4.0
- CVE-2018-7602 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences