Read the docs

Drupal

Records942All Threatist records
Exploited (KEV)8In CISA KEV
CVSS critical56CVSS 9.0–10.0
CVSS high172CVSS 7.0–8.9

Exploited now

Drupal records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

279 records in Drupal · all components

Priority CRITICAL 100KEV

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Drupal Drupal core allows SQL Injection.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.89381 Published 2026-05-20 Fixed in 10.4.10, 10.5.10 +4 CWE-89
Priority CRITICAL 100KEV

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configura…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.99991 Published 2018-03-29 Fixed in 7.58, 8.3.9 +2 CWE-20
TI-2020-10731 CVE-2020-13671 · GHSA-68jc-v27h-vhmw

Unrestricted file upload in Drupal Core

Priority CRITICAL 97KEV

Drupal core does not properly sanitize certain filenames on uploaded files, which can lead to files being interpreted as the incorrect extension and served as the wrong MIME type or executed as PHP for certain hosting co…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.36167 Published 2020-11-20 Fixed in 9.0.8, 8.9.9 +2 CWE-434
Priority CRITICAL 94KEV

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10.

CVSS 3.1HIGH 8.1 Network No auth No interaction EPSS 0.92017 Published 2019-02-21 Fixed in 8.5.11, 8.6.10 +1 CWE-502
TI-2020-08897 CVE-2020-11023 · GHSA-jpcq-cgw6-v4j6

Potential XSS vulnerability in jQuery

Priority CRITICAL 88KEV

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e.

CVSS 3.1MEDIUM 6.9 Network No auth User interaction EPSS 0.84887 Published 2020-04-29 Partial fix · 3.5.0, 4.4.0 CWE-79
TI-2020-08896 CVE-2020-11022 · GHSA-gxr4-xjj5-5px2

jQuery has a potential XSS vulnerability

Priority HIGH 75

In jQuery starting with 1.12.0 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e.

CVSS 3.1MEDIUM 6.9 Network No auth User interaction EPSS 0.99215 Published 2020-04-29 Partial fix · 3.5.0, 4.4.0 +2 CWE-79
Priority HIGH 68

In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted…

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.3595 Published 2019-01-22 Fixed in 7.62, 8.6.6. +3 CWE-20
TI-2017-04646 CVE-2017-6920 · GHSA-9c24-g32g-35rj

Code injection in Drupal Core

Priority MEDIUM 61

Drupal core 8 before versions 8.3.4 allows remote attackers to execute arbitrary code due to the PECL YAML parser not handling PHP objects safely during certain operations.

CVSS 3.0CRITICAL 9.8 Network No auth No interaction EPSS 0.20239 Published 2018-08-06 Fixed in 8.3.4 CWE-19
Priority MEDIUM 57

jQuery-UI is the official jQuery user interface library.

CVSS 3.1MEDIUM 6.5 Network No auth User interaction EPSS 0.40768 Published 2021-10-26 Partial fix · 1.13.0, 7.0.0 CWE-79
Priority MEDIUM 51

Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 7.0 before 7.102, from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00983 Published 2024-12-09 Fixed in 7.102, 10.2.11 +1 CWE-915
Priority MEDIUM 51

Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.0093 Published 2024-12-09 Fixed in 10.2.11, 10.3.9 +1 CWE-915
Priority MEDIUM 51

In Symfony before 2.7.51, 2.8.x before 2.8.50, 3.x before 3.4.26, 4.x before 4.1.12, and 4.2.x before 4.2.7, when service ids allow user input, this could allow for SQL Injection and remote code execution.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.06024 Published 2019-05-16 Fixed in 2.7.51, 2.8.50 +3 CWE-89
Priority MEDIUM 50

Deserialization of Untrusted Data vulnerability in Drupal Core allows Object Injection.This issue affects Drupal Core: from 8.0.0 before 10.2.11, from 10.3.0 before 10.3.9, from 11.0.0 before 11.0.8.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00826 Published 2024-12-09 Fixed in 10.2.11, 10.3.9 +1 CWE-915
Priority MEDIUM 50

The PharStreamWrapper (aka phar-stream-wrapper) package 2.x before 2.1.1 and 3.x before 3.1.1 for TYPO3 does not prevent directory traversal, which allows attackers to bypass a deserialization protection mechanism, as de…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.05436 Published 2019-05-09 Fixed in 2.1.1, 3.1.1 +3 CWE-22
Load more
Open these records in search →