Unrestricted file upload in Drupal Core
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
Drupal core does not properly sanitize certain filenames on uploaded files, which can lead to files being interpreted as the incorrect extension and served as the wrong MIME type or executed as PHP for certain hosting configurations. This issue affects: Drupal Drupal Core 9.0 versions prior to 9.0.8, 8.9 versions prior to 8.9.9, 8.8 versions prior to 8.8.11, and 7 versions prior to 7.74.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | Drupal Core | 9.0 versions prior to 9.0.8; 8.9 versions prior to 8.9.9; 8.8 versions prior to 8.8.11; 7 versions prior to 7.74 | — | No fix listed | CNA |
| — | drupal/core (Packagist) | 9.0.0 to before 9.0.8 | 9.0.8 | Patch available | GHSA-68jc-v27h-vhmw |
| — | drupal/core (Packagist) | 8.9.0 to before 8.9.9 | 8.9.9 | Patch available | GHSA-68jc-v27h-vhmw |
| — | drupal/core (Packagist) | 8.0.0 to before 8.8.11 | 8.8.11 | Patch available | GHSA-68jc-v27h-vhmw |
| — | drupal/core (Packagist) | 7.0.0 to before 7.74 | 7.74 | Patch available | GHSA-68jc-v27h-vhmw |
| — | drupal/drupal (Packagist) | 7.0.0 to before 7.74 | 7.74 | Patch available | GHSA-68jc-v27h-vhmw |
| — | drupal/drupal (Packagist) | 8.0.0 to before 8.8.11 | 8.8.11 | Patch available | GHSA-68jc-v27h-vhmw |
| — | drupal/drupal (Packagist) | 8.9.0 to before 8.9.9 | 8.9.9 | Patch available | GHSA-68jc-v27h-vhmw |
| — | drupal/drupal (Packagist) | 9.0.0 to before 9.0.8 | 9.0.8 | Patch available | GHSA-68jc-v27h-vhmw |
- Drupal Core VendorDrupal Affected 9.0 versions prior to 9.0.8; 8.9 versions prior to 8.9.9; 8.8 versions prior to 8.8.11; 7 versions prior to 7.74 Fixed in — No fix listed CNA
- drupal/core (Packagist) Vendor— Affected 9.0.0 to before 9.0.8 Fixed in 9.0.8 Patch available GHSA-68jc-v27h-vhmw
- drupal/core (Packagist) Vendor— Affected 8.9.0 to before 8.9.9 Fixed in 8.9.9 Patch available GHSA-68jc-v27h-vhmw
- drupal/core (Packagist) Vendor— Affected 8.0.0 to before 8.8.11 Fixed in 8.8.11 Patch available GHSA-68jc-v27h-vhmw
- drupal/core (Packagist) Vendor— Affected 7.0.0 to before 7.74 Fixed in 7.74 Patch available GHSA-68jc-v27h-vhmw
- drupal/drupal (Packagist) Vendor— Affected 7.0.0 to before 7.74 Fixed in 7.74 Patch available GHSA-68jc-v27h-vhmw
- drupal/drupal (Packagist) Vendor— Affected 8.0.0 to before 8.8.11 Fixed in 8.8.11 Patch available GHSA-68jc-v27h-vhmw
- drupal/drupal (Packagist) Vendor— Affected 8.9.0 to before 8.9.9 Fixed in 8.9.9 Patch available GHSA-68jc-v27h-vhmw
- drupal/drupal (Packagist) Vendor— Affected 9.0.0 to before 9.0.8 Fixed in 9.0.8 Patch available GHSA-68jc-v27h-vhmw
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 7.0 to before 7.74; 8.8.0 to before 8.8.11; 8.9.0 to before 8.9.9; 9.0.0 to before 9.0.8 | Vulnerable | Drupal |
| cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* | 32 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* | 33 | Vulnerable | Fedoraproject |
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 7.0 to before 7.74; 8.8.0 to before 8.8.11; 8.9.0 to before 8.9.9; 9.0.0 to before 9.0.8 Vulnerable ·Drupal
- cpe:2.3:o:fedoraproject:fedora:32:*:*:*:*:*:*:* Versions 32 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:33:*:*:*:*:*:*:* Versions 33 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-68jc-v27h-vhmw drupal/core (Packagist) Fixed in 9.0.8 Advisory →
- Fix · GHSA-68jc-v27h-vhmw drupal/core (Packagist) Fixed in 8.9.9 Advisory →
- Fix · GHSA-68jc-v27h-vhmw drupal/core (Packagist) Fixed in 8.8.11 Advisory →
- Fix · GHSA-68jc-v27h-vhmw drupal/core (Packagist) Fixed in 7.74 Advisory →
- Fix · GHSA-68jc-v27h-vhmw drupal/drupal (Packagist) Fixed in 7.74 Advisory →
- Fix · GHSA-68jc-v27h-vhmw drupal/drupal (Packagist) Fixed in 8.8.11 Advisory →
- Fix · GHSA-68jc-v27h-vhmw drupal/drupal (Packagist) Fixed in 8.9.9 Advisory →
- Fix · GHSA-68jc-v27h-vhmw drupal/drupal (Packagist) Fixed in 9.0.8 Advisory →
Vendor assessments
Timeline
- 2022-01-18 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2020-13671
- 2026-10-03 Alias added: GHSA-68jc-v27h-vhmw
References
Advisory 4
Other 8
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/core/CVE-2020-13671.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/drupal/drupal/CVE-2020-13671.yaml
- https://github.com/drupal/core
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5KSFM672XW3X6BR7TVKRD63SLZGKK437
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KWM4CTMEGAC4I2CHYNJVSROY4CVXVEUT
- https://lists.fedoraproject.org/archives/list/[email protected]/message/5KSFM672XW3X6BR7TVKRD63SLZGKK437
- https://lists.fedoraproject.org/archives/list/[email protected]/message/KWM4CTMEGAC4I2CHYNJVSROY4CVXVEUT
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2020-13671
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
- TI-2020-18513 Tar.php in Archive_Tar through 1.4.11 allows write operations with Directory Traversal… KEVCVSS 3.1HIGH 7.5
Sources
- CVE-2020-13671 · CVE Program
- CVE-2020-13671 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-68jc-v27h-vhmw · GitHub Advisory Database · CC BY 4.0
- CVE-2020-13671 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences