Cross-site scripting in Drupal 3rd party module - Search Autocomplete
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
In Drupal's 3rd party module search auto complete prior to versions 7.x-4.8 there is a Cross Site Scripting vulnerability. This Search Autocomplete module enables you to autocomplete textfield using data from your website (nodes, comments, etc.). The module doesn't sufficiently filter user-entered text among the autocompletion items leading to a Cross Site Scripting (XSS) vulnerability. This vulnerability can be exploited by any user allowed to create one of the autocompletion item, for instance, nodes, users, comments.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Drupal | 3rd party module - Search Autocomplete | 7.x-4.x to before 7.x-4.8 | 7.x-4.8 | Patch available | CNA |
- 3rd party module - Search Autocomplete VendorDrupal Affected 7.x-4.x to before 7.x-4.8 Fixed in 7.x-4.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:search_autocomplete_project:search_autocomplete:*:*:*:*:*:drupal:*:* | before 7.x-4.8 | Vulnerable | Search Autocomplete Project |
- cpe:2.3:a:search_autocomplete_project:search_autocomplete:*:*:*:*:*:drupal:*:* Versions before 7.x-4.8 Vulnerable ·Search Autocomplete Project
Remediation
- Fix · CNA 3rd party module - Search Autocomplete (Drupal) Fixed in 7.x-4.8
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7603
- 2026-10-03 Alias added: GHSA-jhjp-3hp8-fjch
References
More Drupal vulnerabilities
- TI-2026-07979 Drupal core - Highly critical - SQL injection - SA-CORE-2026-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05494 Drupal core - Highly critical - Remote Code Execution - SA-CORE-2018-004 KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05493 Improper input validation in Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10731 Unrestricted file upload in Drupal Core KEVCVSS 3.1HIGH 8.8
- TI-2019-04505 Drupal core - Highly critical - Remote Code Execution KEVCVSS 3.1HIGH 8.1
- TI-2020-17477 Archive_Tar through 1.4.10 has :// filename sanitization only to address phar attacks… KEVCVSS 3.1HIGH 7.8
Sources
- CVE-2018-7603 · CVE Program
- CVE-2018-7603 · NVD
- FIRST EPSS
- GHSA-jhjp-3hp8-fjch · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences