Contao before 4.5.7 has XSS in the system log.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Contao before 4.5.7 has XSS in the system log.
Why it matters now
EPSS 0.00839 58th percentileScored 2026-11-07
Fix Fixed contao/contao (Packagist): 4.4.18, 4.5.8contao/core-bundle (Packagist): 4.4.18, 4.5.8, 3.5.35+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | contao/contao (Packagist) | 4.0.0 to before 4.4.18 | 4.4.18 | Patch available | GHSA-pj4j-287j-f742 |
| — | contao/contao (Packagist) | 4.5.0 to before 4.5.8 | 4.5.8 | Patch available | GHSA-pj4j-287j-f742 |
| — | contao/core-bundle (Packagist) | 4.0.0 to before 4.4.18 | 4.4.18 | Patch available | GHSA-pj4j-287j-f742 |
| — | contao/core-bundle (Packagist) | 4.5.0 to before 4.5.8 | 4.5.8 | Patch available | GHSA-pj4j-287j-f742 |
| — | contao/core (Packagist) | 3.0.0 to before 3.5.35 | 3.5.35 | Patch available | GHSA-pj4j-287j-f742 |
| — | contao/core-bundle (Packagist) | 3.0.0 to before 3.5.35 | 3.5.35 | Patch available | GHSA-pj4j-287j-f742 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- contao/contao (Packagist) Vendor— Affected 4.0.0 to before 4.4.18 Fixed in 4.4.18 Patch available GHSA-pj4j-287j-f742
- contao/contao (Packagist) Vendor— Affected 4.5.0 to before 4.5.8 Fixed in 4.5.8 Patch available GHSA-pj4j-287j-f742
- contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.4.18 Fixed in 4.4.18 Patch available GHSA-pj4j-287j-f742
- contao/core-bundle (Packagist) Vendor— Affected 4.5.0 to before 4.5.8 Fixed in 4.5.8 Patch available GHSA-pj4j-287j-f742
- contao/core (Packagist) Vendor— Affected 3.0.0 to before 3.5.35 Fixed in 3.5.35 Patch available GHSA-pj4j-287j-f742
- contao/core-bundle (Packagist) Vendor— Affected 3.0.0 to before 3.5.35 Fixed in 3.5.35 Patch available GHSA-pj4j-287j-f742
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* | 3.0.0 – 3.5.33; 4.4.0 – 4.4.16; 4.5.0 – 4.5.6 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.1.0:-:*:*:*:*:*:* | 4.1.0 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.2.0:-:*:*:*:*:*:* | 4.2.0 | Vulnerable | contao |
| cpe:2.3:a:contao:contao:4.3.0:-:*:*:*:*:*:* | 4.3.0 | Vulnerable | contao |
- cpe:2.3:a:contao:contao:*:*:*:*:*:*:*:* Versions 3.0.0 – 3.5.33; 4.4.0 – 4.4.16; 4.5.0 – 4.5.6 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.1.0:-:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.2.0:-:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·contao
- cpe:2.3:a:contao:contao:4.3.0:-:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·contao
Remediation
- Fix · GHSA-pj4j-287j-f742 contao/contao (Packagist) Fixed in 4.4.18 Advisory →
- Fix · GHSA-pj4j-287j-f742 contao/contao (Packagist) Fixed in 4.5.8 Advisory →
- Fix · GHSA-pj4j-287j-f742 contao/core-bundle (Packagist) Fixed in 4.4.18 Advisory →
- Fix · GHSA-pj4j-287j-f742 contao/core-bundle (Packagist) Fixed in 4.5.8 Advisory →
- Fix · GHSA-pj4j-287j-f742 contao/core (Packagist) Fixed in 3.5.35 Advisory →
- Fix · GHSA-pj4j-287j-f742 contao/core-bundle (Packagist) Fixed in 3.5.35 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-10125
- 2026-10-03 Alias added: GHSA-pj4j-287j-f742
References
Advisory 2
Other 5
- https://contao.org/en/news/contao-3_5_35.html
- https://contao.org/en/news/contao-4_4_18.html
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/contao/CVE-2018-10125.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core-bundle/CVE-2018-10125.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core/CVE-2018-10125.yaml
More Contao vulnerabilities
- TI-2022-09661 Contao Managed Edition v1.5.0 was discovered to contain a remote command execution (RCE)… CVSS 3.1CRITICAL 9.8
- TI-2024-30849 Unrestricted file upload in Contao CVSS 3.1MEDIUM 6.4
- TI-2023-18600 Contao cross site scripting vulnerability via input unit widget CVSS 3.1MEDIUM 6.5
- TI-2022-08709 Cross site scripting via canonical tag CVSS 3.1HIGH 7.2
- TI-2019-08602 Contao 4.x allows SQL Injection. CVSS 3.0CRITICAL 9.8
- TI-2024-30447 Remote command execution through file upload in contao/core-bundle CVSS 3.1HIGH 8.8
Sources
- CVE-2018-10125 · CVE Program
- CVE-2018-10125 · NVD
- FIRST EPSS
- GHSA-pj4j-287j-f742 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences