LibreNMS through 1.47 allows SQL injection via the html/ajax_table.php sort[hostname]…
Priority MEDIUM 41CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
LibreNMS through 1.47 allows SQL injection via the html/ajax_table.php sort[hostname] parameter, exploitable by authenticated users during a search.
Why it matters now
EPSS 0.01378 72nd percentileScored 2026-11-07
Fix Fixed librenms/librenms (Packagist): 1.65
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | librenms/librenms (Packagist) | before 1.65 | 1.65 | Patch available | GHSA-4fwh-r866-pvh9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- librenms/librenms (Packagist) Vendor— Affected before 1.65 Fixed in 1.65 Patch available GHSA-4fwh-r866-pvh9
Remediation
- Fix · GHSA-4fwh-r866-pvh9 librenms/librenms (Packagist) Fixed in 1.65 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-20678
- 2026-10-03 Alias added: GHSA-4fwh-r866-pvh9
References
Advisory 3
More Librenms vulnerabilities
- TI-2018-14479 LibreNMS 1.46 allows remote attackers to execute arbitrary OS commands by using the… CVSS 3.0CRITICAL 9.8
- TI-2026-59134 LibreNMS before 26.8.0 Authentication Bypass via API Token Type Confusion CVSS 4.0CRITICAL 9.2
- TI-2022-03735 Insufficient Session Expiration in librenms/librenms CVSS 3.1CRITICAL 9.8
- TI-2022-03252 Deserialization of Untrusted Data in librenms/librenms CVSS 3.1HIGH 8.8
- TI-2026-05445 OS command injection in librenms CVSS 4.0HIGH 8.5
- TI-2024-34235 LibreNMS before 24.10.0 allows a remote attacker to execute arbitrary code via OS command… CVSS 3.1CRITICAL 9.1
Sources
- CVE-2018-20678 · CVE Program
- CVE-2018-20678 · NVD
- FIRST EPSS
- GHSA-4fwh-r866-pvh9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences